--dir flag to ampinstmgr doesn't appear to work

  • Last Post 14 November 2018
  • Topic Is Solved
tehbam posted this 12 November 2018

OS Name/Version:

Centos 7.5.1804 (Linux Spartan 3.10.0-862.9.1.el7.x8664 #1 SMP Mon Jul 16 16:29:36 UTC 2018 x8664 x8664 x8664 GNU/Linux)

Product Name/Version:

AMP Instance Manager v1.6.10.8

Problem Description:

The --dir flag to specify a custom directory to store instance data in (listed in the amp instance manager help) doesn't appear to work. Using it causes ampinstmgr to spit out its help text, implying that the option isn't recognized. Omitting it causes the instance data directory to end up in what I assume is the default location (/home//.ampdata)

Steps to reproduce:

  1. Attempt to create an instance with the instance data in a non-default directory, using the --dir option, such as the following: ./ampinstmgr --dir <path to="" custom="" location=""> --CreateInstance Minecraft minecraft 8080 <license key=""> <password>
  2. AMP instance manager returns its help text, implying that something about the command is malformed

Actions taken to resolve so far:

  • Tried different syntax (--dir=<blah> instead of --dir <blah>)
  • Tried different positioning of --dir option than specified in help text (at end of CreateInstance command instead of before)

Order By: Standard | Newest | Votes
Mike posted this 12 November 2018

The flag isn't actually implemented yet. It will be removed until it's ready for use.

tehbam posted this 13 November 2018

Ah, ok that makes sense. Is there another way to accomplish the same behavior until the flag gets implemented? I saw the instructions for how to move the location on windows, but it involves changing a registry key, and the normal location for registry keys on linux in mono (/etc/mono/registry) doesn't seem to exist. How does AMP know where to look for the AMP data directory on linux? Is it hardcoded in the binary, or is there some other location for the mono registry that I haven't found yet?


Mike posted this 13 November 2018

It's hardcoded to ~/.ampdata - but the quick answer you're looking for is to use a symlink.

AMP doesn't rely on mono so the registry files you're looking for won't exist :)

tehbam posted this 14 November 2018

Ah, of course! Symlink will work just fine, thanks. I guess I assumed since MCMA2 for linux was mono-based, so was AMP, but that explains why I couldn't find the mono registry.