Factorio fails when creating instance

  • Last Post 07 February 2018
destari posted this 07 February 2018

I get the following error when trying to initialize a Factorio instance

[19:36:47] [Core:System Error]    : [Error] --- Begin Exception Data --- [Error] OS: Linux (x8664/HyperV) [Error] Module: FactorioModule, Version: AMP [Error] Release spec: Release - built by CUBECODERS/BuildBot on CCL-DEV [Error] Instance ID: 0f357297-3130-464a-9a22-b281b9eef1ae [Debug] Starting process /bin/uname [Debug] Working Directory: /home/oca/.ampdata/instances/Factorio [Debug] Arguments: -a [Debug] Started process with ID 2090 [Error] Linux amp1 4.4.0-112-generic #135-Ubuntu SMP Fri Jan 19 11:48:36 UTC 2018 x8664 x8664 x8664 GNU/Linux [Error] [0] (NotImplementedException) : System.NotImplementedException: The method or operation is not implemented. at FactorioModule.FactorioApp.add_UserJoins (System.EventHandler`1[TEventArgs] value) [0x00000] in <052e25fa649848ca8f385cd3ad3b218e>:0 at GSMyAdmin.Core.SetupCommonEvents (ModuleShared.IApplicationWrapper App, GSMyAdmin.PluginMessagePusher MessagePusher) [0x00017] in <2fb393950b7e41829c33756d8bf232b5>:0 at GSMyAdmin.Core.Run () [0x004f3] in <2fb393950b7e41829c33756d8bf232b5>:0 at GSMyAdmin.Program.Main (System.String[] args) [0x00005] in <2fb393950b7e41829c33756d8bf232b5>:0 [Error] --- End Exception Data ---

Mike posted this 07 February 2018

The factorio module isn't ready for use yet, hence why it doesn't show in the main list and gives a "Not Implemented" error. You can use it on the Nightly build without it crashing but it doesn't do much yet.