Failed to login to remote instance

  • 2.2K Views
  • Last Post 3 weeks ago
Nanobug posted this 15 May 2021

Hello Cube Coders,

I'm getting this error message:error message

when I try to manage a target AMP server.

My setup is as following:

  • Proxmox as the host (version 6.4)
  • Ubuntu Server as guest (20.04) - Controller
  • Ubuntu Server as guest (20.04) - Game Server 10
  • Ubuntu Server as guest (20.04) - Game Server 20
  • Ubuntu Server as guest (20.04) - Game Server 30 (inactive)

I'm running this version of AMP on all servers: AMP Release "Ganymede" v2.1.1.4, built 07/05/2021 19:00

I found a thread here that says to set "PassthruAuthLocalOnly" to "False" in the "AMPConcig.conf" file, on the controller. This is what it looks like: enter image description here

Is there a way to fix it?

Order By: Standard | Newest | Votes
ashlyne posted this 17 May 2021

ADS probably has Security.EnablePassthruAuth set to false. try setting it to true and see if that fixes it

Mike posted this 17 May 2021

Your controller probably has the wrong auth server URL and is propagating it to your targets.

Nanobug posted this 21 May 2021

Sorry, busy week. Didn't have time to check up on it.

ADS probably has Security.EnablePassthruAuth set to false. try setting it to true and see if that fixes it

That' on the controller? If yes, where?

Your controller probably has the wrong auth server URL and is propagating it to your targets.

I that the Login.AuthServerURL= in the AMPConfig.conf file? If yes, what should I set it to? The controller?

Mike posted this 5 weeks ago

Yes, it should be set to the URL of the controller. Normally PassthruAuth is enabled by default on the controller in its AMPConfig.conf so it doesn't need touching.

Nanobug posted this 5 weeks ago

Yes, it should be set to the URL of the controller. Normally PassthruAuth is enabled by default on the controller in its AMPConfig.conf so it doesn't need touching.

I've set it to the IP of the controller now, and rebooted ampinstmgr.service, checked it was running, and now I'm having the same problem. Do you have a wiki or something where I can check how to set it up properly?

Mike posted this 5 weeks ago

It should be set up properly OOTB.

Check the auth server URL under New Instance Defaults in the controller, that value gets propagated everywhere.

Nanobug posted this 5 weeks ago

It was set to localhost. It's changed to the controller now, and I've checked every target, and it says the IP of the controller now. I've restarted the controller, but not the targets.

But I still get the same error. I can't figure out what I'm doing wrong here.

Mike posted this 5 weeks ago

Make sure that the AMPConfig.conf has the same matching auth server URL in every individual instance. If you need to change this then the instance must be shut down first.

Nanobug posted this 4 weeks ago

If I did it the correct place, then it's all set to the controller's IP. Do you have a wiki or something somewhere I can look through to make sure everything is set up correct, or can you tell me what setting exactly, because this is what I've been trying to do since you wrote it the first time?

Mike posted this 4 weeks ago

No, there's no wiki article covering this topic.

Can you try deleting your ADSModule.kvp file on your controller and restarting it, then let it re run thru the setup process as a controller.

Nanobug posted this 4 weeks ago

I'll try it later or during the weekend, and get back to you when I've tried it.

Nanobug posted this 4 weeks ago

No, there's no wiki article covering this topic. Can you try deleting your ADSModule.kvp file on your controller and restarting it, then let it re run thru the setup process as a controller.

I tried deleting the files from the command line through SSH, both as the amp user, and as the sudo user, and it didn't work. I can't figure out why. Would it be enough to do it from the webUI?

Nanobug posted this 3 weeks ago

I've decided to start over, and going with Debian instead of Ubuntu this time.

Close