Failed to Start AMP Exit code was 0

  • 27 Views
  • Last Post 2 weeks ago
  • Topic Is Solved
freethemice posted this 2 weeks ago

I updated Amp to latest version and now i get this error

[Debug] Started process with ID 5887
[Info] Waiting for AMP instance to start...
[Error] Failed to start AMP. Exit code was 0
[Info] This instance failed to start. Run './ampinstmgr LastLog MCMA' to view it's most recent log.

This is from LastLog MCMA

[01:13:16] [WebMethods:Core Activity] : Starting the application.
[01:13:16] [MinecraftModule:Core Info] : Java located at /usr/bin/java
[01:13:17] [MinecraftModule:Core Info] : Hash for spigot.jar: 5674374a8797b349a02c9cfbb46f61d6
[01:13:17] [MinecraftModule:Core Info] : Using 'Spigot' compatibility mode.
[01:13:17] [MinecraftModule:Core Debug] : Java located at: /usr/bin/java
[01:13:17] [MinecraftModule:Core Debug] : Java start arguments: -Xmx25000M  -Djline.terminal=jline.UnsupportedTerminal -jar spigot.jar nogui -nojline --log-strip-color
[01:13:17] [ModuleShared:Core Debug] : Starting process /usr/bin/java
[01:13:17] [ModuleShared:Core Debug] : Working Directory: ./Minecraft/
[01:13:17] [ModuleShared:Core Debug] : Arguments: -Xmx25000M  -Djline.terminal=jline.UnsupportedTerminal -jar spigot.jar nogui -nojline --log-strip-color
[01:13:17] [ModuleShared:Core Debug] : Started process with ID 23544
Loading libraries, please wait...
2018-09-12 01:13:19,310 main ERROR Cannot access RandomAccessFile java.io.FileNotFoundException: logs/latest.log (Permission denied) java.io.FileNotFoundException: logs/latest.log (Permission denied)
        at java.io.RandomAccessFile.open0(Native Method)
        at java.io.RandomAccessFile.open(RandomAccessFile.java:316)
        at java.io.RandomAccessFile.<init>(RandomAccessFile.java:243)
        at java.io.RandomAccessFile.<init>(RandomAccessFile.java:124)
        at org.apache.logging.log4j.core.appender.rolling.RollingRandomAccessFileManager$RollingRandomAccessFileManagerFactory.createManager(RollingRandomAccessFileManage:

The minecrast/logs/latest.log is there and 777 for file and folder

I also, ran the spigot jar from terminal and didn't get any errors at all. it ran just fine

Order By: Standard | Newest | Votes
Mike posted this 2 weeks ago

Windows or Linux?

freethemice posted this 2 weeks ago

linux Ubuntu 16.04

Mike posted this 2 weeks ago

Are you running the latest version of the Instance Manager?

freethemice posted this 2 weeks ago

I downloaded from https://cubecoders.com/AMPDownload

freethemice posted this 2 weeks ago

if i try and make a new instance i get this

Running command line: "ping -c 1 -I 0.0.0.0 google.com" from "/root/AMP"
[Error] The specified IP binding address (0.0.0.0) does not have a functioning internet connection (couldn't ping google.com) - please check the network settings for this address and try again.

Mike posted this 2 weeks ago

You're also logged in as root which will stop things working. You must run AMP as a non-root user.

You probably also need to install iputils-ping

Close