File Manager Blank after upgrading to 2.1.0.10

  • 162 Views
  • Last Post 02 March 2021
  • Topic Is Solved
bcwolfen posted this 25 February 2021

Upgraded AMP and both my instances to 2.1.0.10. Running on Debian Linux 'Buster' My Minecraft instance shows all files correctly in File Manager and I am able to interact with those files (IE Download) My Valheim instance shows no files and only the Virtual Backups folder. The Virtual Backups folder shows the backups but I am unable to interact with them. Trying to download a Backup file produces an error page

This 192.168.1.11 page can’t be found No webpage was found for the web address: http://192.168.1.11:8080/fetch/2f6e7eff-7aed-4675-b9ab-be25d2aab1ed/__VDS__Valheim01/GenericApplication/__VDS__LocalBackups/Backups.json
HTTP ERROR 404

All files are visible when I connect to the linux box via FTP. The server is up and running correctly and players are able to join. I have Hard reloaded the browser and emptied cache and cleared cookies.

Order By: Standard | Newest | Votes
Mike posted this 25 February 2021

Disable direct mode file transfers in the file manager configuration.

bcwolfen posted this 25 February 2021

Disabling direct mode did not change it. I also noticed it is only this instance that is affected. When I am using File Manager from the Main Menu, I can navigate to the Valheim01 directory and all the files are there and can be accessed. I downloaded a file from the main directory and also one of the backups out of the Backups directory. If I then enter the Valheim01 instance and access File Manager from there, there are no files, and only the LocalBackups Virtual Directory. I can open that directory but still the files are not accessible.

Mike posted this 26 February 2021

Is this a new instance, or one that was upgraded?

bcwolfen posted this 26 February 2021

Both the Valheim and the Minecraft instance were existing and were upgraded,

Mike posted this 26 February 2021

So it's just the valheim instance that's affected? Getting a few reports of this. Looking into it.

Mike posted this 26 February 2021

The issue has been identified, new instances aren't affected - but a fix has been implemented for older configurations.

  • Liked by
  • bcwolfen
bcwolfen posted this 26 February 2021

Thanks Mike, assuming that will be part of the next update?

Mike posted this 26 February 2021

Indeed.

rabarber posted this 02 March 2021

The issue has been identified, new instances aren't affected - but a fix has been implemented for older configurations.

I still have this issue on 2.1.0.12

Mike posted this 02 March 2021

Older instances need a configuration change, add the folllowing line to GenericModule.kvp for older Valheim instances:

App.BaseDirectory=./Valheim/896660/

Make sure to stop the instance first.

bcwolfen posted this 02 March 2021

Confirmed this works. In my case App.BaseDirectory was set to GenericApplication and I just changed it to Valheim/896660

Close