FTB Direwolf 1.12 : How do I choose the latest 1.4 Pack version ?

  • 363 Views
  • Last Post 17 January 2018
Altheran posted this 24 December 2017

OS Name/Version: UNRAID 6.3.5 ( Dockerized AMP valherun/docker-cc-amp )

Product Name/Version: AMP Release "TN/SR3" v1.5.2.0, built 2017-11-30 19:21

Problem Description:

Right now, AMP downloads the 1.3 Stable Pack version.

https://www.feed-the-beast.com/projects/ftb-presents-direwolf20-1-12/files/2506556

I want the 1.4 Pack

https://www.feed-the-beast.com/projects/ftb-presents-direwolf20-1-12/files/2509788

Whatever I do in the Release Stream field (Stable, Beta, Dev) it doesnt change the downloaded mods.

How do I make it so ? thanks !!

Order By: Standard | Newest | Votes
cloakndagger085 posted this 27 December 2017

Same issue, haven't been able to update to the 1.4 version even using the beta stream.

  • Liked by
  • Altheran
Mike posted this 27 December 2017

Have you restarted AMP since the update was made available? AMP only checks for MC server updates on startup right now.

Altheran posted this 28 December 2017

Even if I manually click the "Install / Update" Button in the Server Sonfiguration tab ?

Altheran posted this 28 December 2017

And I just restarted the container, Mods have not been updated to the versions in the 1.4 pack

and the version.json in \AMP\instances\Instance\Minecraft still says :

{ "forgeVersion": "2555", "mcVersion": "1.12.2", "packVersion": "1.3.0", "packID": "FTBPresentsDirewolf20112", "xml": "modpacks" }

Pack version should read : "packVersion": "1.4.0"

Mike posted this 28 December 2017

In that case the developer haven't published the version in their manifest, AMP gets its list of FTB versions from here:

https://ftb.cursecdn.com/FTB2/static/modpacks.xml

If it isn't in that list, AMP doesn't know about it.

Altheran posted this 01 January 2018

Just made a Thread on FTB side here :

A you telling me the whole thing is dependant on an addition human interaction after having uploaded a new version of a modpack ?

Shouldn't you just parse the hierarchy to grab all the mods, their versions and their respective packs ?

Altheran posted this 01 January 2018

Just made a Thread on FTB side here :

https://forum.feed-the-beast.com/threads/cubecoders-amp-cant-pickup-latest-beta-of-dw1-12.266582/

A you telling me the whole thing is dependant on an addition human interaction after having uploaded a new version of a modpack ?

Shouldn't you just parse the https:// www.feed-the-beast.com/modpacks hierarchy to grab all the mods, their versions and their respective packs ?

Mike posted this 01 January 2018

Link is 404. If the FTB team was sane their modpack list would be updated automatically. Scraping Web pages is a really bad idea, a single style change breaks it immediately and it's broadly slow and inefficient. If a developer doesn't expose an API or a sane datasource to get download information then the server must be uploaded using the file manager.

Altheran posted this 01 January 2018

this is 404 ? (remove the space betwen ''https://'' and ''forum'', the ''ADD POST'' button does nothing if there is a link in my post)

https:// forum.feed-the-beast.com/threads/cubecoders-amp-cant-pickup-latest-beta-of-dw1-12.266582/

Cuz it isn't for me :/

I do understand the advantages of API and formatted standard stuff, but hey, they are not the guys providing a paid service ;)

Imagine a minute that the FTB guys are the only mods being used, and that they do NOT want to have APIs and stuff, because ... let say ... ''ads traffic on their website''.

Your product would loose a lot of appeal if I have to loggin and monitor updates and stuff and manually upload files and make stuff work ... I like AMP because it's simple clic and shoot solution for FTB. Choose server type, modpack, branch and boom, start server. 4 clics and I got a modded server up and running. Otherwise I would have stayed on MCMA2, I had user management and in-game console command, but the no-hassle FTB mods ? Oh yeah ...

So, either code your stuff to grab their stuff without needing them to manage their stuff (cuz they dont quite care about you ''for their existance / revenue''), or manage to talk to the FTB team and collaborate on a better for everybody solution :D

Mike posted this 01 January 2018

It's a FTB 404 page, I removed the space. Does the modpack show up in their launcher? If so they've probably got some new source to get the list of available versions.

Altheran posted this 01 January 2018

it shows on the twitch app .. actually, EVERYTHING shows on the twitch app it upgraded to the 1.4.0 pack as soon as I selected it in the version menu of the mod pack .. maybe there is a way there for you guys to better automate stuff :D

Altheran posted this 17 January 2018

Heeeey, reviving this one ...

The latest beta is now 1.7.1

But now that the Stable is on 1.5.0, AMP got up to 1.5.0, it just can see that there are Betas out there ...

If I go back to the Xml : (4th line if opened in notepadd++)

modpack author="The FTB Team" curseprojectid="281999" .....

lots of stuff ....... then

name="FTB Presents Direwolf20 1.12" oldversions="1.7.1;1.7.0;1.6.0;1.5.0;1.4.0;1.3.0;1.2.0;1.1.0;1.0.0" repoversion="150" serverpack="FTBPresentsDirewolf20112Server.zip" url="FTBPresentsDirewolf20112.zip" version="1.5.0"/modpack

seems that the Betas are specified in "Old Versions" as repoVersion and version say 1.5.0

Close