Hardware change breaks functionality - AMP no longer recognizes virtualization tech

  • Last Post 3 weeks ago
  • Topic Is Solved
shichigatsu posted this 3 weeks ago

System Information:

OS  Fedora 31
System Type     x86_64
Virtualization  None *(this is the issue. Intel VT-x is enabled but AMP can't see it)*
Module  ADSModule
Loaded Plugins  FileManagerPlugin, EmailSenderPlugin, WebRequestPlugin, LocalFileBackupPlugin
Application Name    AMP
Application Version
Release Stream  Release
Build Date  03/09/2020 11:37

Hardware Info:

Intel i7 960
Asus Sabertooth X58 Motherboard/Chipset
24 GB DDR3

Problem Description:

Changed CPU + motherboard from an AMD A10-5800K to an Intel i7 960. Server functionality is stable but the AMP web administration and console commands no longer allow the instances to start. AMP doesn't see that virtualization is enabled. 

Current managed game servers:

7Days2Die Alpha 18.4
7Days2Die Alpha 19

Steps to reproduce:

Step 0: Change hardware - CPU/Motherboard
Step 1: On reboot attempt to launch instances through web administartion 
Step 2: Attempt to launch instances on CLI, ampinstmgr --a
Step 3: ampinstmgr --l shows instances as available, but not running 
Step 4: Verify configuration settings (see imgur album)

Actions taken to resolve so far:

1: Reflash BIOS
2: Turn off VT-x
3: Reboot
4: Turn VT-x back on
5: reboot
6: Verify Fedora can see VT-x
7: Attempt to start servers
8: verify AMP cannot see VT-x

Imgur Album: https://imgur.com/a/CrAtFVz

Order By: Standard | Newest | Votes
Mike posted this 3 weeks ago

Visualisation means whether or not AMP is currently running within a virtual machine, not whether or not the machine is capable of it. This is not an issue. If instances aren't starting you should check their logs to find out why.

shichigatsu posted this 3 weeks ago

So I totally misunderstood how this application works and embarrassed myself here!

ACTUAL issue was the new hardware invalidated the license.

ampinstmgr reactivate ADS01

This, along with the same command for my instances, fixed it in 30 seconds.

Thank you to the forum admins and discord chat folks for educating me on this and dealing with the ignorance here!