How to move server world to MyMcAdmin?

  • 162 Views
  • Last Post 08 December 2018
  • Topic Is Solved
japercaper posted this 07 December 2018

Hello all, I installed MyMcAdmin on my Linux 14 server with no trouble.

Then I copied the world folder from the pre-existing Minecraft folder to the MyMcAdmin folder (and changed user ownership and user group).

When my users logged in, their constructs are all there but everyone's inventory was gone. Also, I'm getting 'permission denied' errors in the logs about savings stats.

All folder and files in the world directory have the correct owner and group as far as I know.

What am I doing wrong?

Thanks - Tom Townsend

Order By: Standard | Newest | Votes
Mike posted this 07 December 2018

Did you change the owner recursively?

japercaper posted this 07 December 2018

I did not - initially. Then I did, but still no inventory for the players.

update: I saw a post somewhere that said I had to copy not just the world directory, but also the jar file. So I'm going to try that.

TomT

japercaper posted this 08 December 2018

Putting in the old jar file generates lots of errors, so I started over. Deleted the world directory; copied in the previous world directory, recursively chown and chgrp; fired up server:

Users reports structures are all there, their inventory is not. They are not too salty about losing inventory. I can op someone to give them back their stuff.

But why isn't their inventory back?

Thanks, TomT

Mike posted this 08 December 2018

Check which user owns the files.

Close