Installed AMP but Instance won't start

  • 372 Views
  • Last Post 19 November 2021
Badwolf15002 posted this 02 November 2021

Windows 10 OS Build: 19043.1288 AMP Version: 2.3.0.2

  • AMP Instance #1 - ADS Wont start after installing AMP

  • When installing i only changed the file path for the Data (Where the instances are located) to /Documents/AMP

  • This is a fresh install but the Instance Manager works but just starting the Instance doesnt work.

  • I have tried to run the installer in 'Repair' then i reboot and nothing. Only thing that happens when i try to start the instance is the CMD pops up and disappears.

  • In the past i had this issue and i used ampinstmgr quickstart but it takes it off from As Service So it no longer starts up automatically etc. It always felt jank afterwards so i just wanted to do a fresh install and have it work properly.

Order By: Standard | Newest | Votes
Badwolf15002 posted this 19 November 2021

I am the admin of the computer and the admin of the folder.

I can add Network service and give them all but "full control" of the folder.

Mike posted this 19 November 2021

You do have permission - it will give you a UAC prompt when you try to.

Badwolf15002 posted this 16 November 2021

No idea. A windows thing I believe.

Mike posted this 15 November 2021

Oh? Why not?

Badwolf15002 posted this 15 November 2021

System language of my computer? Thats English.

And i don't have permission to to give Datastore Network Service full access.

Mike posted this 15 November 2021

Right click the directory -> Properties -> Security -> Edit

Add the "NETWORK SERVICE" user and give it full control over that directory.

I still also need to know if the system language is anything other than in English.

Badwolf15002 posted this 14 November 2021

Uhh how do i check all of this?

Lol i feel inadequate but i am not fimilar to AMP nor it's commands or how it works. So just explains how to do these things please lol.

Mike posted this 14 November 2021

Does the datastore directory allow the NETWORK SERVICE user full access?

Also is the system language something other than English, causing the NETWORK SERVICE user to have a different name?

Badwolf15002 posted this 07 November 2021

Thanks for the helping me with the 'as service' stuff.

But got any clue on why it wont work 'as service' and only works when its not? I want to have to launch when i start the computer and run in the background.

Badwolf15002 posted this 07 November 2021

Yes once it's no longer 'as service' It will run.

Whats the issue that is making it not launch 'as service' ?

ColinsTech posted this 06 November 2021

Right click the instance and select Uninstall service. Running Amp as a service allows it to run at startup. Without having to be launched every time. Rebooting the machine helps sometimes too.

Badwolf15002 posted this 04 November 2021

How do i do that.

Whats the difference between 'as service' and not?

Mike posted this 04 November 2021

If you convert it to a non service instance, does it start?

Badwolf15002 posted this 02 November 2021

  • [18:09:38] [Core Warning]         : Current time zone is set to Central Standard Time - Servers should ideally be UTC to avoid time-zone related issues

  • [18:09:38] [Program Info]         : OS: Windows / x86_64 [18:09:38] [Program Info]         : CPU: AMD Ryzen 9 3950X 16-Core Processor (16C/32T)

  • [18:09:38] [Program Info]         : AMP Instance ID: d79c5618-d605-4e62-b595-309ab100118a [18:09:38] [Program Info]         : Performing first-time setup for this instance, please wait...

  • [18:09:40] [Program Info]         : AMP has completed its first time setup. Saving settings and shutting down.

This is the logs from the AMP #1 Instance

Mike posted this 02 November 2021

Can you check it's logs for me please?

Badwolf15002 posted this 02 November 2021

Ok i have reinstalled AMP and set the Datastore to C:\AMPDatastore. But again the AMP #1 Instance refuses to start.

Mike posted this 02 November 2021

I'd recommend you leave it as something like C:\AMPDatastore\ where AMP can control the permissions.

Badwolf15002 posted this 02 November 2021

C:\Users\BlueBeast\Documents\AMP

Can i install it elsewhere in the C: Drive then?

I simply want it on the same drive as the OS is on. But if i have to have it on a my other drives then fine. (Iv got OCD and bothers me for some reason xP)

Mike posted this 02 November 2021

What's the full path to AMPs datastore? It cannot be in a users home directory.

Close