"Invalid Username or password" on Instance

  • 441 Views
  • Last Post 3 weeks ago
  • Topic Is Solved
Xavalem posted this 3 weeks ago

Hi,

I run an Ubuntu 18.04.1 LTS

with 2 AMP 1.6.10.8 Instances (ADS + Minecraft)

my Problem is I can login in the ADS but not in the Minecraft Instance after update

ADS run with

################################
# Security
################################
Security.AllowConcurrentSessions=True
Security.LogAuthFailures=True
Security.AuthFailureLogPath=./AuthFailures.log
Security.LogSensitiveProcArgs=True
Security.EnablePassthruAuth=True
Security.PassthruAuthLocalOnly=True
Security.TwoFactorMode=Disabled

################################
# Login
################################
Login.AllowInsecureMatching=true
Login.UseAuthServer=False
Login.AuthServerURL=
Login.LDAPAllowAuthOnAnyDomain=False
Login.LDAPAuthDomain=

Minecraft

################################
# Security
################################
Security.ExecPath=Exec
Security.AllowConcurrentSessions=True
Security.LogAuthFailures=True
Security.AuthFailureLogPath=./AuthFailures.log
Security.LogSensitiveProcArgs=False
Security.EnablePassthruAuth=False
Security.PassthruAuthLocalOnly=True
Security.TwoFactorMode=Disabled

################################
# Login
################################
Login.AllowInsecureMatching=true
Login.UseAuthServer=True
Login.AuthServerURL=http://127.0.0.1:8080/
Login.LDAPAllowAuthOnAnyDomain=False
Login.LDAPAuthDomain=

in the log from the Minecraft I See:

[14:05:46] [RemoteAMPAuth:Anonymous Activity] : Authentication attempt for user admin from ip
[14:05:46] [RemoteAMPAuth:Anonymous Activity] : Authentication failure for user admin from ip - Failure

the log from the ADS I See:

[13:59:18] [Auth:Anonymous Activity] : Authentication attempt for user admin from 127.0.0.1
[13:59:18] [Auth:admin Activity]  : Authentication success
[13:59:18] [APIService:admin Warning] : Returned exception from API call
[13:59:18] [Core:admin Error]     : [0] (InvalidDataException) : Token '' is not a valid session ID
[13:59:18] [Core:admin Error]     :   at GSMyAdmin.WebServer.WebMethods.LoginSuccess (GSMyAdmin.WebServer.WebSession session, String username, String token, Boolean rememberMe, Boolean IsServerLogin, Collections.Generic.List`1[T] permissions, String newToken, GSMyAdmin.WebServer.WebMethods+LoginResponse result) 
  at GSMyAdmin.WebServer.WebMethods.Login (m.Http.IHttpRequest request, GSMyAdmin.WebServer.WebSession session, String username, String password, String token, Boolean rememberMe) 
  at GSMyAdmin.WebServer.WebAttributes.InvokeMethod (String MethodName, Newtonsoft.Json.Linq.JObject Data, m.Http.IHttpRequest request, ModuleShared.IWebSession Session, ModuleShared.WebMethodsBase MethodsClass, String RawRequest) 
  at GSMyAdmin.WebServer.APIService.InvokeAPI (m.Http.IHttpRequest request, ModuleShared.IWebSession Session, Newtonsoft.Json.Linq.JObject Data, String RequestModule, String RequestMethod, String RawRequest) 

some one an idea?

Order By: Standard | Newest | Votes
Mike posted this 3 weeks ago

You need to login via ADS itself and then managing the instance from there, you can't log into the instance directly.

Xavalem posted this 3 weeks ago

Thx .... but only my Chrom browser still works the Manage from ADS and than i get

11/20/2018 16:57:59  :admin
16:57:59 Remote login token requested by admin on ip
11/20/2018 16:57:59: Anonymous
16:57:59 Authentication attempt for user admin from 127.0.0.1
11/20/2018 16:58:01: admin
16:58:01 Authentication success
11/20/2018 16:58:01 :Anonymous
16:58:01: Access denied: You do not have permission to use this method (WebMethods.GetAMPUserInfo) at this time. This method requires the Session.LoggedIn permission. (Origin: 127.0.0.1:57728)

Mike posted this 3 weeks ago

Make sure all of your instances are the same version, you may also need to explicitly log out and back in again to clear the credentials cache if you've updated recently.

Xavalem posted this 3 weeks ago

Hi,

all instances are the same Version 1.6.10.8!

I tried :

  • new Instance (same login Problem)
  • clear the caches Server + Browser restart the Framework (no Result)
  • test Login from other pc (same)
  • disabled security rules (... same)

Mike posted this 3 weeks ago

On ADS set Security.PassthruAuthLocalOnly to False.

Xavalem posted this 3 weeks ago

I changed the property! i rebooted the system , clear the cache ...... and had the same problem!

Mike posted this 3 weeks ago

Did you explicitly log out using the user menu in the top left?

Xavalem posted this 3 weeks ago

I tried it again with clean log out and it still doesn't work sry

Access denied: You do not have permission to use this method (WebMethods.GetAMPUserInfo) at this time. This method requires the Session.LoggedIn permission. (Origin: 127.0.0.1:40152)

Mike posted this 3 weeks ago

Does a new instance have the same issue?

Xavalem posted this 3 weeks ago

yes I create an second Minecraft instance with the same result

the Instance log of the Minecraft says

Authentication success

and the ADS I get the error ...

tomorrow I get an new test environment there I can try an complete new installation ..... give it an installation/configuration instruction for Ubuntu 18 LTS + ADS Setup ?

have you requirements where I have to look for?

Xavalem posted this 3 weeks ago

...... so in an new Server it works! .... but why???..... ok so i will try to clean my main Server drop all of the AMP installation and try an complete new Installation ....

Xavalem posted this 3 weeks ago

so it works .... but the configs are the same .... I don't know why but it works after reinstall all ....

Close