Is it possible to specify which java version a minecraft server should start with?

  • 121 Views
  • Last Post 02 August 2019
  • Topic Is Solved
Xericore posted this 02 August 2019

Hi,

OS Name/Version:

Ubuntu 18.04.2 LTS (GNU/Linux 4.15.0-55-generic x86_64)

Product Name/Version:

AMP Release "TITAN" v1.8.3.2, built 31/07/2019 14:40


I have a Minecraft Server with McMyAdmin. Is it possible to specify e.g. in a config file or somewhere else which JDK it should use when starting?

My problem is that right now I have openjdk 11 installed and some Minecraft plugins have problems with that. I'd like to install openjdk-8-jre-headless for Minecraft, but my Atlassian software needs openjdk 11.

All services are running on different users of course, thus my next try would be to ensure AMP has JAVA_HOME set to openjdk-8 and atlassian to openjdk-11. Any other suggestions to solve my problem?

Thanks

Order By: Standard | Newest | Votes
Mike posted this 02 August 2019

You can edit Java.Path in MinecraftModule.kvp to specify the full path to the java executable you want it to use.

Xericore posted this 02 August 2019

Nice, thank you.

Close