Issues with ADS Passthru Instance Management when using HTTPS/SSL

  • 94 Views
  • Last Post 15 July 2019
wessims.jr posted this 12 July 2019

OS Name/Version: Ubuntu 18.04.2

Product Name/Version: AMP Release "TITAN" v1.8.2.2, built 05/07/2019 11:38 / ADS Core Module

Problem Description: After working to get the internal AMP web server switched to use HTTPS/SSL you are unable to use the Passthru Management function to manage child Instances. An Error is thrown stating an HTTP request error. IP address and usernames have been removed.One thing I did notice is that in both the logs and ampinstmgr that the addresses for the servers show in http.

UI Error:

Http Request An error occurred while sending the request Thrown by the 'Core' plugin while performing the 'GetAPISpec' method. Related Link: Advanced Details at Net.WebOperation.Run () at Net.WebCompletionSource`1[T].WaitForCompletion () at Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) at ADSModule.WebMethods.Servers (m.Http.IHttpRequest request, String id, String REQ_RAWJSON)

Except from Logs:

[18:15:52] [ADS:ampuser Activity]   : Managed remote instance Minecraft at http:/// [18:15:52] [Auth:ampuser Activity]  : Authentication token for ampuser requested by ManageInstance on behalf of ampuser [18:15:52] [ADS:Anonymous Error]  : Failure to make API call to Minecraft (http:///) - retried 10 times : An error occurred while sending the request [18:15:52] [Core:Anonymous Error] : [0] (HttpRequestException) : An error occurred while sending the request [18:15:52] [Core:Anonymous Error] : at ADSModule.WebMethods.Servers (m.Http.IHttpRequest request, String id, String REQ_RAWJSON) [18:15:52] [Core:Anonymous Error] : 1 (WebException) : Error getting response stream (ReadDoneAsync2): ReceiveFailure [18:15:52] [Core:Anonymous Error] : at Net.WebOperation.Run ()

ampinstmgr -l output:

[Info] Starting Ins[Info] AMP Instance Manager v1.8.2.2 built 05/07/2019 11:39 [Info] Release spec: Release - built by CUBECODERS/BuildBot on CCL-DEV Instance ID │ Module
│ ADS Instance Name │ ADS01 Friendly Name │ ADS01 URL
│ http://:/ Running │ Yes Runs in Container │ No Start on Boot │ Yes AMP Version │ 1.8.2.2 Release Stream │ Mainline Data Path │ /home/AMP/.ampdata/instances/ADS01

Instance ID │ Module │ McMyAdmin Instance Name
│ Minecraft Friendly Name │ Minecraft URL │ http://:/ Running │ Yes Runs in Container │ No Start on Boot │ No AMP Version │ 1.8.2.2 Release Stream │ Mainline Data Path │ /home/AMP/.ampdata/instances/Minecraft

Instance ID │ Module │ Minecraft Instance Name
│ Minecraft01 Friendly Name │ Minecraft Bedrock Edition URL
│ http://:/ Running │ Yes Runs in Container │ No Start on Boot │ No AMP Version │ 1.8.2.2 Release Stream │ Mainline Data Path │ /home/AMP/.ampdata/instances/Minecraft01

Steps to reproduce:

Stopped all Instances

Followed instructions on wiki for using HTTPS: CubeCoders/AMP Wiki Setting up HTTPS with AMP

Started Instances

Actions taken to resolve so far:

Verified the instance.json

Verified changes in conf file: .ampdata/instances/*/AMPConfig.conf

Verified sites can be accessed independently via direct address or IP

Order By: Standard | Newest | Votes
Mike posted this 15 July 2019

You need to edit the AMPConfig.conf of the individual instances to update the AuthServerURL to be HTTPS after making the change.

wessims.jr posted this 15 July 2019

AuthServerURL's has already been set up on all nodes. As stated authenticating on individual nodes, by manually navigating to each port address, is not an issue and works. However logging into the ADS node and clicking the manage button to access each node through passthrough does not and produces the error above. Also tried setting the ADS node to Login.UseAuthServer=True, however this breaks Authentication on the ADS node.

Edit:corrected post for code notation.

AMPConfig.conf - ADS01

################################
# Login
################################
Login.UseAuthServer=False
# Login.AuthServerURL - The URL for the ADS instance providing authentication when using UseAuthServer
Login.AuthServerURL=https://*:8443/
Login.LDAPAllowAuthOnAnyDomain=False
Login.LDAPAuthDomain=

AMPConfig.conf - Minecraft01

################################
# Login
################################
Login.UseAuthServer=True
# Login.AuthServerURL - The URL for the ADS instance providing authentication when using UseAuthServer
Login.AuthServerURL=https://*:8443/
Login.LDAPAllowAuthOnAnyDomain=False
Login.LDAPAuthDomain=

AMPConfig.conf - Minecraft02

################################
# Login
################################
Login.UseAuthServer=True
# Login.AuthServerURL - The URL for the ADS instance providing authentication when using UseAuthServer
Login.AuthServerURL=https://*:8443/
Login.LDAPAllowAuthOnAnyDomain=False
Login.LDAPAuthDomain=

Mike posted this 15 July 2019

What about newly created instances, can you manage those?

wessims.jr posted this 15 July 2019

Inically if left in Http it works no problem. After switching to Https for the new Instance it fails again. I wonder if I have missed something during the original Https setup. Would It be a better ideal to remove all instances and start from scratch?

Close