Latest AMP update - no longer able to start Minecraft servers.

  • 1K Views
  • Last Post 2 days ago
  • Topic Is Solved
guy_davis posted this 2 weeks ago

Sorry, I tried to reply to an existing discussion but no posts were allowed. So starting a new one instead:

Also unable to launch Minecraft servers since last update to the Docker image.

AMP Release "Triton" v2.3.0.4, built 19/11/2021 15:58

Screenshots, can't seem to display them here:

https://ibb.co/cCGzZ4j

https://ibb.co/KGVLFmx

https://ibb.co/99vtLCp

https://ibb.co/BL80w7V

https://ibb.co/rwkDLTf

EDIT on 2021-11-28: Both MS Edge and Google Chrome refuse to post any reply to this forum, so am trying to edit my previous one. They have an error in browser console.

What I would like to reply with: Thanks, please point me to this official image. I'm on Unraid, so using "mitchtalmadge/amp-dockerized" from the Unraid Community Apps section.

Order By: Standard | Newest | Votes
Mike posted this 2 weeks ago

If it's the latest version of Minecraft, it requires Java 17 which the docker image doesn't have yet. For now disable the docker option and reactivate the instance. Once the support outage ends I'll be able to address this properly.

toomeek posted this 2 weeks ago

I'm running couple Minecraft servers inside LXC container, which works just fine on the latest Triton.
My java version is:

openjdk version "1.8.0_262"
OpenJDK Runtime Environment (AdoptOpenJDK)(build 1.8.0_262-b10)
OpenJDK 64-Bit Server VM (AdoptOpenJDK)(build 25.262-b10, mixed mode)

Mike posted this 5 days ago

Nightly build of AMP has a new docker image base for newer versions of Minecraft with JDK 17 included.

MitchTalmadge posted this 2 days ago

What I would like to reply with: Thanks, please point me to this official image. I'm on Unraid, so using "mitchtalmadge/amp-dockerized" from the Unraid Community Apps section.

Hiya! You are using my docker image. The error in the console is saying that you are running an outdated Java version. This is probably because I removed Java 16 and added Java 17 in the last update. Please go to the Java section of the settings (see your 3rd screenshot) and change the version from 11 to 17. I hope it helps, and I apologize for the confusion.

  • Liked by
  • guy_davis
Close