MCMA 2 server start after boot?

  • 996 Views
  • Last Post 5 weeks ago
  • Topic Is Solved
Ben3721 posted this 20 February 2019

Forgive me for another naive question. How do I make my server start automatically on PC boot? I'm expecting some power outages tomorrow but wont be around to log in and start the server every time it goes down.

Im pretty sure I have mcmyadmin 2 installed as a service, I think, how do I check?

Thank you for your help.

Order By: Standard | Newest | Votes
Ben3721 posted this 16 March 2019

I'm still trying to figure this out. So far I have learned how to setup services to start automatically. However I do not see a service for mcma, is this because I'm starting mcma with McMyAdmin.exe? Does that prevent it from starting as a service? I'm feeling dumber than a box of rocks trying to figure this out. I should also mention this is on windows 10.

Mike posted this 16 March 2019

If you selected the "Install as service" option during installation then you can use the Services control panel built into Windows to change its startup mode.

Ben3721 posted this 16 March 2019

What is it titled as in the service control panel? I checked multiple times and couldn't find it. I really thought I selected that box on install. Did I break it by starting it with the mcmyadmin.exe? How do I start it as a server manually? In the service panel as well? Thanks for the help.

Ben3721 posted this 16 March 2019

How do I start it as a service manually* sorry typo.

Mike posted this 16 March 2019

If it's not in the services control panel as "McMyAdmin" then you need to re-run the setup.

Ben3721 posted this 16 March 2019

I'm starting to think my install had a error after reviewing the install logs. Maybe I don't understand so I posted them below.

Mcma_service.installlog https://pastebin.com/4xK6sZij

Installutil.installlog https://pastebin.com/5FzpJngf

Mike posted this 17 March 2019

The service already exists it says there, so you're not looking properly in the services control panel.

Ben3721 posted this 5 weeks ago

McMyAdmin service isnt showing in my service control panel. Really confused as I have checked a dozen times. Probably going to re-install it yet again to see if it pops up. If I doesn't then something is preventing it, while probably user error I still will have to figure it out. Maybe its because I set the location of the MCMA files to another drive during install? I'm really not sure.

EDIT: I just read the MCMA Service Readme.txt and think it might be the correct fix to my issue. Ill try it when no one is playing,

Close