MCMA 3: Console stops outputting when certain user joins

  • Last Post 18 June 2019
  • Topic Is Solved
icannotread posted this 16 June 2019

OS Name/Version:
Ubuntu 19.04

Product Name/Version:
AMP v1.8.1.2 (McMyAdmin 3)

Problem Description:
As soon as a player named '365' joins, it shows his UUID and join message in console then output ceases. If I refresh the panel, console is blank and never populates. However, commands entered still work properly despite them not showing up after being entered. I haven't seen this problem come up for any other users.
Edit: after further testing, when I kick this user, console function returns.

Steps to reproduce:
- Start server
- Check console, should be working
- User 365 joins server
- Console output ceases

Actions taken to resolve so far:
Not sure how to go about troubleshooting. The issue isn't present in McMyAdmin 2, but I have no idea where to go from here.
Edit 2: One thing I have tried after a bit of reading around was ctrl+f5; this made no difference.

Order By: Standard | Newest | Votes
Mike posted this 16 June 2019

Interesting, can you see if there's anything in the browsers F12 error console?

icannotread posted this 16 June 2019

Here's what I'm seeing (I'd post a screenshot but I can't seem to add a post that contains a picture):
UI.js:994 Uncaught TypeError: name.toLowerCase is not a function at HTMLDivElement.<anonymous> (UI.js:994) at Function.each (jquery-3.2.1.min.js:3) at r.fn.init.each (jquery-3.2.1.min.js:3) at Object.AddConsoleEntries (UI.js:991) at handleNofify (AMP.js:1181) at processPushedMessage (AMP.js:1138) at (API.js:56) (anonymous) @ UI.js:994 each @ jquery-3.2.1.min.js:3 each @ jquery-3.2.1.min.js:3 AddConsoleEntries @ UI.js:991 handleNofify @ AMP.js:1181 processPushedMessage @ AMP.js:1138 @ API.js:56

Mike posted this 16 June 2019

Aah, I see the problem! It'd occur with any username that was just a number. There'll be a fix for this in the next update.

icannotread posted this 16 June 2019

Awesome, thanks for the speedy replies!

Mike posted this 18 June 2019

The fix didn't make it into the most recent update, but it will be soon.

  • Liked by
  • icannotread