McMyAdmin fails to update Java runtime for Minecraft

  • 183 Views
  • Last Post 12 June 2021
ABCDWHAT posted this 12 June 2021

When I attempt to update Minecraft Server to 1.17 (in the new Java version) McMyAdmin returns this error:

JNI error has occurred, please check your installation and try again thread "main" java.lang.UnsupportedClassVersionError: net/minecraft/server/Main has been compiled by a more recent version of the Java Runtime (class file version 60.0), this version of the Java Runtime only recognizes class file versions up to 52.0

I have tried to update Java over ssh, but it does not change the outcome.

Mike posted this 12 June 2021

You shouldn't use McMyAdmin any more. Please upgrade to AMP as soon as possible. AMP has handling for multiple java versions on the same system, McMyAdmin can only use the system default.

Close