Minecraft 1.17 Java

  • 563 Views
  • Last Post 3 weeks ago
milfer322 posted this 3 weeks ago

When I try to create a minecraft server with the latest version, I get the following error:

java.lang.UnsupportedClassVersionError: net / minecraft / server / Main has been compiled by a more recent version of the Java Runtime (class file version 60.0), this version of the Java Runtime only recognizes class file versions up to 55.0

How can update it? I need wait for update AMP?

Thanks!

  • Liked by
  • Listerman69
Order By: Standard | Newest | Votes
Listerman69 posted this 3 weeks ago

Same Here. Even uninstalled full java and reinstalled just to be sure i had the latest version on my windows machine. Java 8 version 291 Please help is required. Thank you

milfer322 posted this 3 weeks ago

I updated java to 16.0.1 and changed it from instance => Java to jdk-16.0.1

Listerman69 posted this 3 weeks ago

I updated java to 16.0.1 and changed it from instance => Java to jdk-16.0.1 I have update it to the latest on my windows machine where i run AMP. Or do i need still to do something else on AMP

milfer322 posted this 3 weeks ago

I updated java to 16.0.1 and changed it from instance => Java to jdk-16.0.1 I have update it to the latest on my windows machine where i run AMP. Or do i need still to do something else on AMP

I fix it with that in linux

Listerman69 posted this 3 weeks ago

I found the isseu i was using the normal java and not the devolopmet kit version. Is fixed for me now But strqnge that 1.16.5 had no problem running on that version of java

LeGeccio posted this 3 weeks ago

A quick workaround is to manually install openjdk-16 and change the java path in the module

Steps:
sudo apt install openjdk-16-jre
sudo nano /home/amp/.ampdata/instances/[INSTANCE_NAME]/MinecraftModule.kvp

adjust the line:
Java.CustomPath=/usr/bin/java

The Java version/path could be found with which java

Close