Minecraft Java instance will not start on Raspberry Pi 4

  • Last Post 3 weeks ago
soldemeyer posted this 4 weeks ago

OS Name/Version: 64-bit version of Ubuntu 20.10 ARM on a 8GB Raspberry Pi 4

Product Name/Version: CubeCoders Amp

Problem Description: Minecraft Java instance will not start

Steps to reproduce:

Created a new Minecraft Java instance. Instance appears to be starting but stops after ~20 seconds.

Log file can be seen here:

[14:32:46] [Core Warning]         : Current time zone is set to MST - Servers should ideally be UTC to avoid time-zone related issues
[14:32:46] [Core Info]            : OS: Linux / aarch64
[14:32:46] [Core Info]            : CPU: ARM Cortex-A72 (4C/4T)
[14:32:46] [Core Info]            : AMP Instance ID: 8b8e71ec-1965-4cfa-a56d-1514d35baa78
[14:32:46] [ModuleLoader Info]    : Loaded MinecraftModule version by CubeCoders Limited
[14:32:46] [Minecraft Warning]    : Failed to get latest forge version data from http://files.minecraftforge.net/maven/net/minecraftforge/forge/maven-metadata.xml
[14:32:46] [Core Error]           : WebException
[14:32:46] [Core Error]           : [0] (WebException) : An exception occurred during a WebClient request.
[14:32:46] [Core Error]           :   at MinecraftModule.UpdateManager.GetForgeUpdateData () 
[14:32:46] [Core Error]           : NotSupportedException
[14:32:46] [Core Error]           : [1] (NotSupportedException) : The URI prefix is not recognized.
[14:32:46] [Core Error]           :   at Net.WebRequest.Create (Uri requestUri, Boolean useUriBase) 
  at Net.WebRequest.Create (Uri requestUri) 
  at Net.WebClient.GetWebRequest (Uri address) 
  at Net.WebClient.DownloadStringAsync (Uri address, Object userToken) 
[14:32:46] [Core Info]            : Metrics publishing is enabled at udp://localhost:12820.
[14:32:46] [ModuleLoader Info]    : Loaded FileManagerPlugin version by CubeCoders Limited
[14:32:46] [ModuleLoader Info]    : Loaded EmailSenderPlugin version by CubeCoders Limited
[14:32:46] [ModuleLoader Info]    : Loaded WebRequestPlugin version by CubeCoders Limited
[14:32:46] [ModuleLoader Info]    : Loaded LocalFileBackupPlugin version by CubeCoders Limited
[14:32:46] [ModuleLoader Info]    : Loaded CommonCorePlugin version by CubeCoders Limited
[14:32:47] [FileManager Notice]   : No SSH keypair available for embedded server, generating new keypair...
[14:32:47] [FileManager Notice]   : Generated new keypair with fingerprint ZiqziAVk9abZQUbA9KmO5Rhe3FyK+DRGlPdsENZBd0U=
[14:32:47] [FileManager Notice]   : Using keypair with fingerprint ZiqziAVk9abZQUbA9KmO5Rhe3FyK+DRGlPdsENZBd0U=
[14:32:47] [FileManager Info]     : SFTP Server started on
[14:32:47] [Core Error]           : No valid AMP licence was found. Please run `ampinstmgr reactivate test` to reactivate this instance.

Actions taken to resolve so far:

-I made sure Amp as up to date. -I ensured Java was installed -I tried running ampinstmgr reactivate test as mentioned in the log.

None of these things seemed to help

I'm not sure what do to from here? Any suggestions?

Order By: Standard | Newest | Votes
Mike posted this 4 weeks ago

Ah I forgot about this. AMP can't currently activate itself on the Pi. I will look into it.

soldemeyer posted this 3 weeks ago

Thanks for taking a look at this! Is there anything I can do from my side to help try and resolve this?

Mike posted this 3 weeks ago

Try the latest version. I changed a few things but I haven't tested yet.

soldemeyer posted this 3 weeks ago

Still no luck. I get the same error.

jarrodthebobo posted this 3 weeks ago

I'm currently having the same issue as well. I've tried pretty much everything but cannot get the server to authenticate