Missing installer for 1.7.5.0 when trying to upgrade Amp to 1.8.2.0

  • 50 Views
  • Last Post 04 July 2019
  • Topic Is Solved
supersej posted this 26 June 2019

When I try to upgrade, reinstall or uninstall my Amp Instance Manager from version 1.7.5.0 to 1.8.2.0 i get the following message "The feature you are trying to use is on a network resource that is unavailable"

It keeps asking for AMPsetup.msi that corresponds to version 1.7.5.0, but I don't have this file anymore. Pointing to the new 1.8 Ampsetup.msi is not fixing the problem. So now I am stuck on 1.7 :(

Can you please help me getting a copy of AmpSetup.msi for version 1.7.5.0 so I can continue my upgrade.

Best regards Daniel

Order By: Standard | Newest | Votes
supersej posted this 04 July 2019

The answer to this problem is actually rather simple... When you know what to do. Learned from a similar problem at work that a simple registryfix can solve this problem.

In my case, [HKEYLOCALMACHINE\SOFTWARE\Classes\Installer\Products\CA9016DFA90C9114893C976359C880C5\SourceList] "PackageName"="AMPSetup.msi" pointed at AMPSetup.msi This was the old AMPSetup.msi file I sadly don't have anymore

So all I did was just delete the whole key referring to Amp Instance Manager WARNING - Please export key before you delete - Just in case something goes wrong (so you can import again)

The key I deleted was HKEYLOCALMACHINE\SOFTWARE\Classes\Installer\Products\CA9016DFA90C9114893C976359C880C5 It should have the subkey "ProductName"="AMP Instance Manager"

After this key was deleted, there was no reference to the old MSI and the new version installed perfectly :)

Mike posted this 27 June 2019

You should just be able to install the new version over-the-top without the old MSI (which unfortunately does not exist any more) - if that doesn't work don't sweat it there's other ways to sort it :)

supersej posted this 26 June 2019

Oh and I am running Amp from a Windows 2019 server. I have searched for the Ampsetup file on my computer and on google with no luck

Close