Only ADS and basic Minecraft instances launch

  • 192 Views
  • Last Post 23 February 2018
  • Topic Is Solved
unknowjondoe posted this 20 February 2018

I know I am probably doing something wrong so feel free to point it out. I am running on Ubuntu and got ADS installed first then when I tried to make any other instance they didn't work except for the Minecraft one. I am using the same IP settings and changing the AMP Port for each one. I can't see any other key settings that would be an issue.

I have only been using this for a few hours so I am probably missing something. Thanks for any help.

Order By: Standard | Newest | Votes
Mike posted this 20 February 2018

Check the logs for the specific instances. Chances are they'll tell you what's wrong and what to do about it.

unknowjondoe posted this 21 February 2018

This might be a dumb question but where is the error log?

unknowjondoe posted this 21 February 2018

I found the log and it says "Waiting for AMP instance to start..." Then says "Failed to start AMP. Exit code was 0"

Mike posted this 21 February 2018

It's in the instance directory. That line is from ADS/AIM, not from the AMP instance you're trying to start. Assuming you're on Linux you can find the directory by running ./ampinstmgr list

unknowjondoe posted this 22 February 2018

Okay I found it. Different instances are saying different things. MCMyAdmin is saying its license key is invalid. And StarBound is saying this.

[18:23:11] [Core:System Error]    : No application module specified. Please specify one in your AMP configuration file, or re-run the instance manager. [18:23:11] [Core:System Error]    : ERROR building certificate chain: System.Threading.ThreadAbortException at System.Security.Cryptography.X509Certificates.X509Chain.Build (System.Security.Cryptography.X509Certificates.X509Certificate2 certificate) [0x00006] in <284c8916baa7426e854207bb68427ea7>:0 at Mono.Net.Security.SystemCertificateValidator.BuildX509Chain (System.Security.Cryptography.X509Certificates.X509CertificateCollection certs, System.Security.Cryptography.X509Certificates.X509Chain chain, System.Net.Security.SslPolicyErrors& errors, System.Int32& status11) [0x00016] in <284c8916baa7426e854207bb68427ea7>:0 [18:23:11] [Core:System Error]    : Please, report this problem to the Mono team

I haven't tested with other ones but the only Instances that run are the ADS and just basic Minecraft ones.

Mike posted this 22 February 2018

I think you'll need to recreate those instances. May also be worth adding the --nightly flag to get the absolute latest version.

unknowjondoe posted this 22 February 2018

I have rebuilt both and get the same result. I am going to try the system on a different computer to see what happens.

unknowjondoe posted this 23 February 2018

It seems it was an error with the server I setup. It is all working now.

Close