Oracle 8.5 OCI AMP Install Failing on aarch64

  • 19 Views
  • Last Post 3 days ago
  • Topic Is Solved
SigmaApex posted this 2 weeks ago

Hi - The installation documentation notes AMP requires GLIBC 2.18+ however 2.29 is listed as a dependency when being installed via YUM.

# yum install ampinstmgr
Last metadata expiration check: 1:25:27 ago on Sat 08 Jan 2022 08:19:32 PM GMT.
Error:
 Problem: conflicting requests
  - nothing provides libm.so.6(GLIBC_2.29)(64bit) needed by ampinstmgr-2.3.0.8-2.aarch64

Oracle Linux 8.5:

# ldd --version
ldd (GNU libc) 2.28

Can you help clarify? Oracle Linux doesn't support GLIBC 2.29 on aarch64 it would seem.

Thanks!

Order By: Standard | Newest | Votes
Mike posted this 2 weeks ago

Only Ubuntu is officially supported on AArch64 right now pretty much for this reason. If you're using Oracle Cloud they have an option to provision with Ubuntu. 2.18 is for x86/64

  • Liked by
  • SigmaApex
SigmaApex posted this 3 days ago

Thanks Mike!

Close