Permission error with java through AMP

  • 51 Views
  • Last Post 5 weeks ago
  • Topic Is Solved
Cublix posted this 10 November 2017

Hi,

Does anyone know why this may be happening? I've checked permissions on all the paths listed. The administrator has full access but is still having problems with accessing java. Do I need to grand the admin account in AMP administrator access? If so, how?

I'm actually desperate this has my head melted. Any help at all.

java.nio.file.AccessDeniedException: C:\Users\Administrator\AppData\Local\CubeCoders\AMP\Instances\Cublix\Minecraft\minecraftserver.jar at sun.nio.fs.WindowsException.translateToIOException(Unknown Source) ~[?:1.8.0151] at sun.nio.fs.WindowsException.rethrowAsIOException(Unknown Source) ~[?:1.8.0151] at sun.nio.fs.WindowsLinkSupport.getRealPath(Unknown Source) ~[?:1.8.0151] at sun.nio.fs.WindowsPath.toRealPath(Unknown Source) ~[?:1.8.0151] at sun.nio.fs.WindowsPath.toRealPath(Unknown Source) ~[?:1.8.0151] at com.sun.nio.zipfs.ZipFileSystemProvider.newFileSystem(ZipFileSystemProvider.java:111) ~[zipfs.jar:1.8.0151] at java.nio.file.FileSystems.newFileSystem(Unknown Source) ~[?:1.8.0151] at java.nio.file.FileSystems.newFileSystem(Unknown Source) ~[?:1.8.0151] at ns.a(SourceFile:133) [minecraftserver.jar:?] at ns.a(SourceFile:73) [minecraftserver.jar:?] at ns.(SourceFile:66) [minecraftserver.jar:?] at oo.b(SourceFile:164) [minecraftserver.jar:?] at net.minecraft.server.MinecraftServer.a(SourceFile:281) [minecraftserver.jar:?] at nz.j(SourceFile:233) [minecraftserver.jar:?] at net.minecraft.server.MinecraftServer.run(SourceFile:434) [minecraftserver.jar:?] at java.lang.Thread.run(Unknown Source) [?:1.8.0_151]

Order By: Standard | Newest | Votes
Mike posted this 10 November 2017

Relocate the datastore outside of the Administrators appdata directory. If this is your first instance it might be easier to reinstall and put the datastore in C:\AMP\ or something.

Cublix posted this 5 weeks ago

Relocate the datastore outside of the Administrators appdata directory. If this is your first instance it might be easier to reinstall and put the datastore in C:\AMP\ or something.

Mike I don't think you know how much I love you right now. Thank you very much sir.

Can I also ask if there's a way to manage craftbukkit plugins in AMP. I can see there's a spigot plugins feature. When I look in installed pluggins' it says no plugins are installed even though they are in the directory. The same plugins I wasn't running fine on MCMYADMIN2.

Thank you.

Mike posted this 5 weeks ago

Make sure AMP is on v1.5. Craftbukkit and spigot plugins are the same thing.

Close