Rebinding Instances is not possible

  • Last Post 04 December 2017
  • Topic Is Solved
FlayInAHook posted this 03 December 2017

Since its a long time problem now that rebinding instances is not possible I decided to post the problem here.

So I just want to quickly rebind all of my web interfaces because I got a 2nd IP. But Its simply not possible. The quintessence of the log says "The IP address and port combination is already in use by another instance." nevertheless, I posted the whole exception here. I have the following setup for my instances setup and I want to issue this command ./ampinstmgr --RebindInstance EHGMC 25577 but it doesn't let me. I also tried ./ampinstmgr --RebindInstance EHGMC 25578 this before the other command to avoid the same port but it didn't work. Stopping all instances before didn't help either. I know that I could edit every config file of the web interfaces but this would cost me so much time. I hope you can fix this :)

Order By: Standard | Newest | Votes
Mike posted this 03 December 2017

What's the output of ./ampinstmgr -l ?

FlayInAHook posted this 04 December 2017

instances setup

Here you can find it

Mike posted this 04 December 2017

Well it's behaving correctly. You've got another instance on that same port number bound to every IP address (

You'd have to rebind that instance to a specific IP address or use a different port.

FlayInAHook posted this 04 December 2017

But I did this with the commands? I'd even rebinded it to another port before to prevent such behavior.

Mike posted this 04 December 2017

The instance called EHGMC is already bound to 25577 (so it won't let you rebind to the same port) and LeonardFamilie is using port 25578.

FlayInAHook posted this 04 December 2017

my dumbness has no boundaries.. thx for the help :)