SecureChannelFailure (The authentication or decryption has failed.) on login for Minecraft module

  • 731 Views
  • Last Post 17 July 2018
Wolfe posted this 16 July 2018

OS Name/Version: Arch Linux Kernel version: 4.16.13-2-ARCH x64

Product Name/Version: AMP Instance Manager v1.6.9.0 built 28/06/2018 12:53 and AMP version 1.6.9.0 (TN/SR5-B), built 28/06/2018 12:52

Problem Description: When attempting to login to the minecraft module web panel it says " Login server unreachable " and the following is written in the logs:

[12:55:18] [Core:Anonymous Error] : [0] (AggregateException) : One or more errors occurred.
[12:55:18] [Core:Anonymous Error] :   at Threading.Tasks.Task.ThrowIfExceptional (Boolean includeTaskCanceledExceptions)
  at Threading.Tasks.Task`1[TResult].GetResultCore (Boolean waitCompletionNotification)
  at Threading.Tasks.Task`1[TResult].get_Result ()
  at GSMyAdmin.Authentication.RemoteAMPAuth.Authenticate (m.Http.IHttpRequest Request, String Username, String Password, String Token, Boolean Toke    nRequested, Collections.Generic.List`1[String]& Permissions, String& NewToken, String& ConfirmedUsername)
[12:55:18] [Core:Anonymous Error] : [1] (WebException) : Error: SecureChannelFailure (The authentication or decryption has failed.)
[12:55:18] [Core:Anonymous Error] :   at Net.HttpWebRequest.EndGetRequestStream (IAsyncResult asyncResult)
  at Net.WebClient.UploadBitsRequestCallback (IAsyncResult result)
  at AMPAPI.RemoteInstance.GetResponseDynamic ()
  at AMPAPI.RemoteInstance.Core_Login ()
[12:55:18] [Core:Anonymous Error] : [2] (IOException) : The authentication or decryption has failed.
[12:55:18] [Core:Anonymous Error] :   at Mono.Security.Protocol.Tls.SslStreamBase.EndRead (IAsyncResult asyncResult)
  at Mono.Net.Security.Private.LegacySslStream.EndAuthenticateAsClient (IAsyncResult asyncResult)
  at Mono.Net.Security.Private.LegacySslStream.AuthenticateAsClient (String targetHost, Security.Cryptography.X509Certificates.X509CertificateColle    ction clientCertificates, Security.Authentication.SslProtocols enabledSslProtocols, Boolean checkCertificateRevocation)
  at Mono.Net.Security.MonoTlsStream.CreateStream (Byte[] buffer)
  at Net.WebConnection.CreateStream (Net.HttpWebRequest request)
[12:55:18] [Core:Anonymous Error] : [3] (IOException) : The authentication or decryption has failed.
[12:55:18] [Core:Anonymous Error] :   at Mono.Security.Protocol.Tls.SslClientStream.EndNegotiateHandshake (IAsyncResult result)
  at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallback (IAsyncResult asyncResult)
[12:55:18] [Core:Anonymous Error] : [4] (TlsException) : The authentication or decryption has failed.
[12:55:18] [Core:Anonymous Error] :   at Mono.Security.Protocol.Tls.RecordProtocol.EndReceiveRecord (IAsyncResult asyncResult)
  at Mono.Security.Protocol.Tls.SslClientStream.SafeEndReceiveRecord (IAsyncResult ar, Boolean ignoreEmpty)
  at Mono.Security.Protocol.Tls.SslClientStream.NegotiateAsyncWorker (IAsyncResult result)

Steps to reproduce:

Use ampinstmgr to create a ADSInstance.
Use that ADSInstance to create a Minecraft instance.
Try to log into that Minecraft instance.

I've tried using mozroots to update my certificates and tried recreating the instance after re-installing.

Mike posted this 17 July 2018

Is your ADS instance set up to use SSL?

Close