Server Randomly Shutting Down

  • 166 Views
  • Last Post 21 June 2021
  • Topic Is Solved
kylemcisaac posted this 16 June 2021

My Java Minecraft server has been randomly shutting down. Cannot understand why. The server starts fine (takes anywhere from a minute to two to load the world data, etc), then after a few moments just shuts down. A log is attached at: https://pastebin.com/E344nLTc

Server is running Windows Server 2019 with two cores and16GB RAM. The Minecraft configuration has 4GB of memory configured and is vanilla. Running AMP 2.1.1.8 Ganymede.

Order By: Standard | Newest | Votes
AbhorrentJoel posted this 16 June 2021

My thought is that you may have a performance issue with your server that is causing your Minecraft server to hit the max-tick-time limit. Usually it is set to 60000, and you can check in the Gameplay and Difficulty menu in AMP. If you set it to -1 and it no longer shuts down, then you will need to look elsewhere. I think two cores with Windows Server is pushing it.

fafdk posted this 17 June 2021

I think HDD issues, this is not on SSD right? If on HDD, how much space left?

Can you give a some more spec on hardware, CPU, Model, MB?

kylemcisaac posted this 17 June 2021

I was able to get the server from stopping randomly by setting the max tick to 120000, but as for performance, it still takes a while to start up.

As for the system: It's a Dell PowerEdge T410 server with dual-Xeon E5620 @ 2.4GHz (total of 16 logical processors) with 64GB of RAM and six 2TB drives in raid 10 totaling 6TB of storage with redundancy. It is running on a Virtual Machine with specs of 4 virtual processors and 16GB of RAM.

Mike posted this 17 June 2021

Minecraft is mostly single threaded so it doesn't benefit from multiple CPU cores. You're limited by a 2.4GHz chip there.

kylemcisaac posted this 17 June 2021

Yeah, that's the unfortunate side. I do have a Bedrock server running at the same time (which just starts instantly without the typical Java overhead) with just 1GB of RAM. Increasing the tick time seems to have done it, as well as disabling auto-sleep.

fafdk posted this 21 June 2021

Which Hypervisor do you use?

VirtIO SCSI drivers?

I know that your CPU is not the fastest, but you might squeeze out some extra performance on the SCSI.

Also, your HDDs, are they SAS 10K, 15K or 7.2K, or SATA 7.2K ??? I know that Raid 10 is fast, but you should really think about popping in a SSD is you haven't already, and test it out.

Every single bit in the chain matters IMHO. I managed to get rid of these warnings after using SSD, even on a lower spec i3 CPU.

Close