Sleep Mode not working on Paper Spigot Server

  • 55 Views
  • Last Post 26 October 2020
  • Topic Is Solved
Kirschi posted this 23 October 2020

OS Name/Version: Windows 10 Pro, Version 2004 (Build 19041.572)

Product Name/Version: AMP Release "Europa" v2.0.7, built 19/10/2020 15:35

Problem Description:

Every time I start the Minecraft-Server inside the instance, I find this in the logs:

[13:22:58] [Minecraft:Kirschi Warning] : Sleep packet timestamp doesn't match!
[13:22:58] [System:Kirschi Warning] : Unable to get protocol version. Sleep mode will be unavailable.

And unfortunately, this is true. Sleep mode doesn't work. Is this because of Paper Spigot, Spigot in general or is there any problem I'm not aware of? Could it have got something to do with this?:

[13:22:09] [Core Warning]         : Current time zone is set to W. Europe Standard Time - Servers should ideally be UTC to avoid time-zone related issues

Order By: Standard | Newest | Votes
Mike posted this 23 October 2020

Indeed, having the wrong time zone will cause issues. AMP expects everything to be UTC.

Kirschi posted this 23 October 2020

I've tried changing my time zone to UTC, unfortunately it didn't help at all. Also there seems to be no way to change the time zone for just 1 user, so that wouldn't be a viable option anyway.

I don't get it, what's the problem here?

Kirschi posted this 25 October 2020

Update:

I've set up 2 more servers now, a 1.16.3 Forge Server and a 1.12.2 Forge Server. With both servers the sleep mode works without any problems. My 1.16.3 Spigot Server still isn't able to go into sleep mode though.

Mike posted this 26 October 2020

Sleep mode is only available if AMP is able to connect to the server and make sense of the response. If sleep mode is unavailable that's pretty much the end of it, AMP has determined that it's unable to offer the functionality to that particular server and can't do anything about it. Sleep is not available for all server types.

Close