Spigot not automated

  • Last Post 12 January 2019
  • Topic Is Solved
Jeff posted this 12 January 2019

OS Windows Server R12 Amp ver 1.71 Problem: Decided to try spigot for server, so selected server as Spigot, and when I selected update, got the buildtools.jar in spigotbuild directory, but nothing else. So I manually executed buildtools, which went flawlessly, no errors in log. The spigot_ver.jar that was generated, I renamed spigot.jar, copied to the ./minecraft directory. I started the jar manually, which generated the usual folders and files, then stopped java manually. When I tried to start server manually, would not start. Noted in logs that there was a permission error for the spigot.jar, which seemed to correct itself after I used the AMP file manager to refresh files. After that the server started flawlessly (although I have not yet started messing with plugins). Also, I did manually set the jar to spigot.jar. So it works, but my main criticism is that the update and generation of the spigot.jar does not seem at all automated. Doing things manually was simple, as git and java are installed and paths set.

Mike posted this 12 January 2019

It is automated, but Windows Server is super awkward with the permissions and Java doesn't supply enough information about why. If you run BuildTools outside of AMP (but not as admin!) it may give you more information about why.