Unable to manage instances using custom endpoint

  • Last Post 04 April 2021
  • Topic Is Solved
slowmochives posted this 03 April 2021

OS Name/Version: Both servers are using Debian 10.9 Buster

Product Name/Version: Amp

Background: I have nginx running on one server and AMP running on another. The nginx server accepts traffic on port 80 and 443 from the internet, and I have it configured to act as a reverse proxy for AMP.

I would like to avoid using "https://mydomain.com" for AMP (which I have done in the past and worked fine). Instead, I would like to use "https://mydomain.com/amp". I have the nginx location set up for "/amp", and I confirmed that the main AMP page actually works fine. Browsing to "https://mydomain.com/amp" brings me to the main AMP page, I can log in, view/create instances, etc.

Problem Description: However, when I try to click "Manage" for an instance, nothing actually happens. If I look at the browser console, and I can see that it first browses to


and then it browses to


On that second call, since it's not including the "/amp" endpoint, it's browsing to my reverse proxy and not reaching AMP.

Actions taken to resolve so far:

  1. Confirmed that I can manage the instance if I do not use the custom endpoint (specify "/" as the location in the nginx site instead of "/amp/").
  2. Tried adding "/amp/" to the auth server values of the AMPConfig.conf (did not resolve, reverted).
  3. Tried finding an answer on Google, but I couldn't find anyone else running into this issue.

Final Questions: Is using a custom endpoint in this manner supported with AMP? If so, is there any documentation for setting this up properly?

Order By: Standard | Newest | Votes
Mike posted this 03 April 2021

You must use a subdomain. So amp.mydomain.com rather than a path.

slowmochives posted this 03 April 2021

Ah, I hadn't thought of that. I'll try it when I get home later today. Thanks!

slowmochives posted this 04 April 2021

Thank you for the suggestion! It worked like a charm.