Unable to Re-install AMP

  • Last Post 07 December 2019
  • Topic Is Solved
crainbramp posted this 28 November 2019

Issue: Cannot Reinstall AMP OS: Server 2016

One of the servers I'm using for AMP (I have the Network edition) had the drive die that AMP was installed to (a tertiary drive). Although I managed to successfully uninstall it, the uninstall was just one of those things where Windows removes it from the list of installed programs.

Have deleted all the AMP directories I could find, including the datastore, which was on yet another drive. I've also deleted all registry keys I could find.

However, AMP will not re-install. It continues to complain that D: drive (the drive that failed) is not available, and the installer simply quits.

Any suggestions on how to do this without a total re-install?

Thanks, Don

Order By: Standard | Newest | Votes
Mike posted this 28 November 2019

The registry key you're looking for is HKLM\SOFTWARE\CubeCoders\AMP\InstanceManager - make sure you're using the 64 bit version of Regedit or the key won't show up.

crainbramp posted this 28 November 2019


The key doesn't exist; as I stated, I did a search through the registry for "cubecoders" and deleted everything I found. Just for verification, I ran %systemroot%\syswow64\regedit again and double-checked just now, and it's definitely not there.

AMP doesn't list itself as installed in Windows either, and since the original drive is gone, there are no AMP directories, although I've double-checked again.

Here are the errors I'm getting:



As Always, Don

Mike posted this 29 November 2019

Not too sure then. Only thing I can suggest is that you use the Disk Manager to create+mount a VHDX file as a virutal hard drive, give it the driver letter D: and restart the installer so you can change the target directory, and then unmount the virtual drive once you're done.

Uninstalling apps with the source drive missing is something that's going to cause issues, leaving it alone and editing the registry entries instead would have likely been the easier route.

crainbramp posted this 07 December 2019

I just went ahead moved the two servers I had on Windows this was happening to (I still have a couple of other dedis running Windows) to Ubuntu. Thanks for the help though.