Unable to start instance after moving physical servers and IP

  • 59 Views
  • Last Post 2 weeks ago
  • Topic Is Solved
BROOKSBY posted this 2 weeks ago

OS Name/Version: Unraid Hypervisor / Ubuntu 19.10 OS

Product Name/Version: AMP 1.9.6.4 / McMyAdmin Module (Latest)

Problem Description: Unable to start instance after moving physical server and IP

Details: Server was running in VM Manager on Synology nas running Ubuntu 19.10, I exported this and imported into unraid. Changed the static ip from 192.168.1.141 to 192.168.1.55. Upon starting the server and going into the AMP panel with my existing details the instance wont start.

Actions taken to resolve so far: 1. Checked to see if Instance can be found via terminal ampinstmgr -l (nothing found) 2. Changed ADS Auth server on McMyAdmin01 instance via File Manager from 192.168.1.141 to 192.168.1.55 3. Tried creating another instance via McMyAdmin03 module, said I had a invalid license so I logged into cubecoders.com and downloaded a new license key and applied. 4. I then attempted to start the exisiting instance which failed 5. Tried to create another instance again as above which failed still saying my license is invalid.

Order By: Standard | Newest | Votes
BROOKSBY posted this 2 weeks ago

Just checked the AMP_logs folder inside McMyAdmin instance and there is

[12:24:39] [Core Info]            : Running in a QEMU KVM environment.
[12:24:39] [Core Info]            : OS: Linux / x86_64
[12:24:39] [Core Info]            : CPU: Intel(R) Celeron(R) CPU G1610T @ 2.30GHz (2C/2T)
[12:24:39] [Core Info]            : AMP Instance ID: bb93b01c-9989-4a63-88a5-d327f9339293
[12:24:39] [Core Notice]          : Running as McMyAdmin 3
[12:24:40] [ModuleLoader Info]    : Loaded MinecraftModule version 1.0.0.3 by CubeCoders Limited
[12:24:40] [ModuleLoader Info]    : Loaded FileManager version 1.0.0.0 by CubeCoders Limited
[12:24:40] [ModuleLoader Info]    : Loaded EmailSender version 1.0.0.0 by CubeCoders Limited
[12:24:40] [ModuleLoader Info]    : Loaded WebRequestPlugin version 1.0.0.0 by CubeCoders Limited
[12:24:40] [ModuleLoader Info]    : Loaded LocalFileBackupPlugin version 1.0.0.0 by CubeCoders Limited
[12:24:40] [Core Error]           : No valid AMP licence was found. Please run `ampinstmgr reactivate McMyAdmin01` to reactivate this instance.

So I ran "ampinstmgr reactivate McMyAdmin01" on my server, entered my license key and got [Error] No such instance matching name: McMyAdmin01

Mike posted this 2 weeks ago

You need to be logged in as the amp user to run ampinstmgr commands.

  • Liked by
  • BROOKSBY
BROOKSBY posted this 2 weeks ago

Ok, I attempted that and it says I need to stop ADS. Is that as simple as running ampinstmgr -o ?

BROOKSBY posted this 2 weeks ago

Got it working.

I ran ampinstmgr -o then the reactivate command via amp user. I then had to change the IP of the auth server

Thanks

Close