Update Issue with ADS installation

  • 457 Views
  • Last Post 16 September 2019
OnklSwörny posted this 13 July 2019

Hello,

i get the following error when i want to manage an instance from ADS:

Cannot manage this instance This instance is not the same version as this ADS installation. ADS is version 1.8.0.2 but this instance is version 1.8.2.2

I downloaded the last installer an install it but every time i get this message.

Please give me a hint to fix this. Thx

OnklSwörny

Order By: Standard | Newest | Votes
Mike posted this 15 July 2019

You need to update ADS itself. ampinstmgr upgradeall on the command line/ssh as the user that AMP is running as will take care of that.

OnklSwörny posted this 21 July 2019

I ran ampinstmgr upgradeall with the user who started the amp application instance but no luck

This this the output:

C:\Users\User>ampinstmgr upgradeall
[Info] AMP Instance Manager v1.8.2.2 built 05/07/2019 11:39
[Info] Release spec: Release - built by CUBECODERS/BuildBot on CCL-DEV
[Info] Upgrading instance Minecraft01
[Info] Using cached archive: C:\AMPDatastore\Instances\AMPCache-1822.zip
[Info] Upgrade complete.
[Info] Upgrading instance Minecraft02
[Info] Using cached archive: C:\AMPDatastore\Instances\AMPCache-1822.zip
[Info] Upgrade complete.
[Info] Upgrading instance Minecraft03
[Info] Using cached archive: C:\AMPDatastore\Instances\AMPCache-1822.zip
[Info] Upgrade complete.

AMP Version still on 1.8.0.2, any ideas?

Onkl

Mike posted this 22 July 2019

What's the output of 'ampinstmgr table'?

OnklSwörny posted this 22 July 2019

Output:

Microsoft Windows [Version 6.3.9600]
(c) 2013 Microsoft Corporation. Alle Rechte vorbehalten.

C:\Users\Administrator>ampinstmgr table

[Info] AMP Instance Manager v1.8.2.2 built 05/07/2019 11:39
[Info] Release spec: Release - built by CUBECODERS/BuildBot on CCL-DEV
Instance Name      │ Friendly Name    │ Module     │ IP              │ Port  │ Up
───────────────────┼──────────────────┼────────────┼─────────────────┼───────┼───
Minecraft01        │ Minecraft        │ Minecraft  │ 0.0.0.0         │ 8082  │ V
Minecraft02        │ Onkls Minecraft  │ Minecraft  │ 0.0.0.0         │ 8081  │
Minecraft03        │ Onkls Vanilla... │ Minecraft  │ 0.0.0.0         │ 8083  │ V

maraudir posted this 22 July 2019

EDIT: Found my hosting provider messed up my DNS servers and I couldn't resolve. Fixed it in /etc/resolv.conf

Sorry to hijack but I too have an upgrade issue:

[Info] AMP Instance Manager v1.8.2.2 built 05/07/2019 11:39
[Info] Release spec: Release - built by CUBECODERS/BuildBot on CCL-DEV
[Info] Stopping Instance: 'ADS01'
[Info] Stopping instance ADS01...
[Info] Waiting for instance to stop...
[Info] Instance ADS01 has stopped.
[Info] Upgrading instance ADS01
[Error] Failed to unpack AMP.
[Error] [0] (WebException) : Error: NameResolutionFailure
[Error]   at Net.WebOperation.Run ()
  at Net.WebCompletionSource`1[T].WaitForCompletion ()
  at Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult)
  at Net.WebClient.GetWebResponse (Net.WebRequest request, IAsyncResult result)
  at Net.WebClient.GetWebResponseTaskAsync (Net.WebRequest request)
  at Net.WebClient.DownloadBitsAsync (Net.WebRequest request, IO.Stream writeStream, ComponentModel.AsyncOperation asyncOp, Action`3[T1,T2,T3] completionDelegate)
  at InstanceManagerPlugin.LocalInstanceManager.DownloadAndUnpack (InstanceManagerPlugin.LocalAMPInstance Spec, Boolean ModuleOnly, Boolean SkipCache)
[Info] Upgrade complete.
[Info] Upgrading instance Minecraft01
[Error] Failed to unpack AMP.
[Error] [0] (WebException) : Error: NameResolutionFailure
[Error]   at Net.WebOperation.Run ()
  at Net.WebCompletionSource`1[T].WaitForCompletion ()
  at Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult)
  at Net.WebClient.GetWebResponse (Net.WebRequest request, IAsyncResult result)
  at Net.WebClient.GetWebResponseTaskAsync (Net.WebRequest request)
  at Net.WebClient.DownloadBitsAsync (Net.WebRequest request, IO.Stream writeStream, ComponentModel.AsyncOperation asyncOp, Action`3[T1,T2,T3] completionDelegate)
  at InstanceManagerPlugin.LocalInstanceManager.DownloadAndUnpack (InstanceManagerPlugin.LocalAMPInstance Spec, Boolean ModuleOnly, Boolean SkipCache)
[Info] Upgrade complete.
[Info] Waiting for AMP instance to start...
[Notice] AMP instance ADS01 is now running.

Mike posted this 24 July 2019

NameResolutionFailure indicates you've still got DNS issues. You can do nslookup cubecoders.com and nslookup google.com to test your DNS.

OnklSwörny posted this 13 September 2019

Hello,

i still get the following error when i want to manage an instance from ADS:

Cannot manage this instance This instance is not the same version as this ADS installation. ADS is version 1.8.0.2 but this instance is version 1.8.5.2

I downloaded the last installer an install it but every time i get this message.

Please give me a hint to fix this. Thx

OnklSwörny

Mike posted this 14 September 2019

Run the command above I gave as the first answer.

OnklSwörny posted this 14 September 2019

`Microsoft Windows [Version 6.3.9600]

(c) 2013 Microsoft Corporation. Alle Rechte vorbehalten.

C:\Users\Administrator>ampinstmgr upgradeall

[Info] AMP Instance Manager v1.8.5.2 built 07/09/2019 15:44

[Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV

[Info] Stopping Instance: 'Minecraft01'

[Info] Stopping instance Minecraft01...

[Info] Requesting soft-stop...

[Info] Waiting for instance to stop...

[Info] Instance Minecraft01 has stopped.

[Info] Upgrading instance Minecraft01

[Info] Using cached archive: C:\AMPDatastore\Instances\AMPCache-1852.zip

[Info] Upgrade successful

[Info] Upgrading instance Minecraft02

[Info] Using cached archive: C:\AMPDatastore\Instances\AMPCache-1852.zip

[Info] Upgrade successful

[Info] Stopping Instance: 'Minecraft03'

[Info] Stopping instance Minecraft03...

[Info] Requesting soft-stop...

[Info] Waiting for instance to stop...

[Info] Instance Minecraft03 has stopped.

[Info] Upgrading instance Minecraft03

[Info] Using cached archive: C:\AMPDatastore\Instances\AMPCache-1852.zip

[Info] Upgrade successful`

C:\Users\Administrator>ampinstmgr table

[Info] AMP Instance Manager v1.8.5.2 built 07/09/2019 15:44

[Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV

Instance Name │ Friendly Name │ Module │ IP │ Port │ Up

Minecraft01 │ Minecraft │ Minecraft │ 0.0.0.0 │ 8082 │

Minecraft02 │ Onkls Minecraft │ Minecraft │ 0.0.0.0 │ 8081 │

Minecraft03 │ Onkls Vanilla... │ Minecraft │ 0.0.0.0 │ 8083 │

C:\Users\Administrator>

Is all like the last time i posted the issue. I think update won't work anymore and i have to delete all and start from scratch. :(

Or any other idea, why it won't work for me.

OnklSwörny

Mike posted this 16 September 2019

You're logged in as the wrong user - you shouldn't be running anything related to AMP as Administrator.

OnklSwörny posted this 16 September 2019

Under which User the "AMP Aplication Instance" Service must run? My runs under NetworkService.

Ok, i restart the server an logged in as normal user. Then i start the AMP Manager an it shows me an Update. I download the Update an installed it. Then the AMP Manager says that there were Instances that must be updated. I try to update the instances from the AMP Manager but the application stops working any time.

OnklSwörny posted this 16 September 2019

On normal User i get a failure everytime i start: ampinstmgr upgradeall something about "....DOTNet.zip...." With ampinstmgr table it shows me all instances now on 1.8.5.4.

It seems that all instances now on 1.8.5.4 but in the webinterface, i get still the failure when i won't to manage an instance from ADS.

Cannot manage this instance This instance is not the same version as this ADS installation. ADS is version 1.8.0.2 but this instance is version 1.8.5.4

OnklSwörny posted this 16 September 2019

I startet the service ("AMP Aplication Instance") now as normal User an the Update works.

Microsoft Windows [Version 6.3.9600]
(c) 2013 Microsoft Corporation. Alle Rechte vorbehalten.

    C:\Users\Onkl>ampinstmgr upgradeall
    [Info] AMP Instance Manager v1.8.5.4 built 16/09/2019 16:00
    [Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV
    [Info] Upgrading instance Minecraft01
    [Info] Using cached archive: C:\AMPDatastore\Instances\AMPCache-1854.zip
    [Info] Upgrade successful
    [Info] Upgrading instance Minecraft02
    [Info] Using cached archive: C:\AMPDatastore\Instances\AMPCache-1854.zip
    [Info] Upgrade successful
    [Info] Upgrading instance Minecraft03
    [Info] Using cached archive: C:\AMPDatastore\Instances\AMPCache-1854.zip
    [Info] Upgrade successful

    C:\Users\Onkl>

C:\Users\Onkl>ampinstmgr table
[Info] AMP Instance Manager v1.8.5.4 built 16/09/2019 16:00
[Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV
Instance Name      │ Friendly Name    │ Module     │ IP              │ Port  │ U
p
───────────────────┼──────────────────┼────────────┼─────────────────┼───────┼──
─
Minecraft01        │ Minecraft        │ Minecraft  │ 0.0.0.0         │ 8082  │

Minecraft02        │ Onkls Minecraft  │ Minecraft  │ 0.0.0.0         │ 8081  │

Minecraft03        │ Onkls Vanilla... │ Minecraft  │ 0.0.0.0         │ 8083  │



C:\Users\Onkl>

But if i logged in to ADS i get still the message:

Cannot manage this instance This instance is not the same version as this ADS installation. ADS is version 1.8.0.2 but this instance is version 1.8.5.4

if i wan't to manage an instance from ADS :(

Diagnostics Data
Field   Value
OS  Windows
Platform    Microsoft Windows Server 2012 R2 Standard
System Type x86_64
Virtualization  HyperV
Module  ADSModule
Loaded Plugins  FileManager, EmailSender, PushBulletPlugin, LocalFileBackupPlugin
Application Name    AMPService
Application Version 1.8.0.2
Release Stream  Release
Build Date  22/05/2019 10:44
InstanceID  d53a87f8-b321-4c8d-9de5-d7a63609ed48
Last Executable C:\AMPDatastore\Instances\Minecraft03\AMP.exe
Last Arguments  +Core.Webserver.Port "8083" +Core.Webserver.IPBinding "0.0.0.0" +MinecraftModule.Minecraft.PortNumber "25566"

Mike posted this 16 September 2019

You need to update ADS itself, you didn't try and delete your ADS instance at any point did you? Because something is very wrong if it doesn't even show up in your instances list.

OnklSwörny posted this 16 September 2019

Hi Mike,

no i don't delete anythink, but the installation was some time ago. What do you think is the quickes way to get it work again?

I have only 3 Instances so i can backup the AMP Datastore, uninstall the whole application reinstall it an recover the datastore. It is possible?

If not i will start from scratch, thanks for your help.

Onkl

Close