[Solved] Upgrade from previous version, now won't start

  • 154 Views
  • Last Post 29 January 2018
  • Topic Is Solved
Stratbasher posted this 28 January 2018

Hello,

Running CentOS 7, I think my last version that I was running was 1.4.8.2? Just did a ./ampinstmgr --UpgradeInstance Creative (my Minecraft Creative instance) and now, I get the following stack trace in LastAMPException.txt

[Error] --- Begin Exception Data ---
[Error] OS: Linux (x86_64/HyperV)
[Error] Module: MinecraftModule, Version: AMP 1.6.0.0
[Error] Release spec: Release - built by CUBECODERS/BuildBot on CCL-DEV
[Error] Instance ID: 4fea6b5d-53eb-4b7a-bfa5-7cb2ad0ae9d1
[Debug] Starting process /bin/uname
[Debug] Working Directory: /home/AMP/.ampdata/instances/Creative
[Debug] Arguments: -a
[Debug] Started process with ID 15779
[Error] Linux LGS01 3.10.0-693.11.6.el7.x86_64 #1 SMP Thu Jan 4 01:06:37 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
[Error] [0] (NullReferenceException) : System.NullReferenceException: Object reference not set to an instance of an object
  at LocalFileBackupPlugin.PluginMain.PostInit () [0x00043] in <f26961ed90dd4978b2a65ff917b1db68>:0
  at GSMyAdmin.ModuleLoader.RunPostInit () [0x000cb] in <2fb393950b7e41829c33756d8bf232b5>:0
  at GSMyAdmin.Core.LoadPlugins (GSMyAdmin.ModuleLoader Loader, GSMyAdmin.Config Config, ModuleShared.IApplicationWrapper app, Microsoft.Practices.Unity.IUnityContainer container, ModuleShared.ILogger log) [0x00062] in <2fb393950b7e41829c33756d8bf232b5>:0
  at GSMyAdmin.Core.Run () [0x00505] in <2fb393950b7e41829c33756d8bf232b5>:0
  at GSMyAdmin.Program.Main (System.String[] args) [0x00005] in <2fb393950b7e41829c33756d8bf232b5>:0
[Error] --- End Exception Data ---

Any ideas? I've deleted and re-downloaded the update, removed / renamed the "Plugins" folder, etc. Any help would be appreciated!

Order By: Standard | Newest | Votes
Mike posted this 29 January 2018

In AMPConfig.conf is the FileManager plugin in the list of plugins to load?

Stratbasher posted this 29 January 2018

Solved. I recreated the instances.

Close