Warning : Unable to detect java version! Java may not be installed or may be outdated.

  • 262 Views
  • Last Post 14 August 2019
  • Topic Is Solved
joelgeri1@gmail.com posted this 14 August 2019

i have an ubuntu 18.04.3 LTS system with the openjdk version 11 and 8 running on the server but evertime i try to run McMyAdmin i get the error " Warning : Unable to detect java version! Java may not be installed or may be outdated." bellow is my server log

Notice  : Detecting System...
Notice  : No virtualized environment detected.
Notice  : Linux Distribution: Ubuntu
Notice  : Detection complete.
Warning : No Minecraft configuration file found (Normal on a first start)
Warning : Unable to detect java version! Java may not be installed or may be outdated.

im not sure what to try i have installed 3 different versions of java and have a cleanish install of ubuntu running

Order By: Standard | Newest | Votes
Mike posted this 14 August 2019

What's the output of `java -version? Also you should try starting anyway and see if it's able to continue. It's just a version check.

Also as an aside ideally you should use AMP rather than McMyAdmin 2 if possible for anything new.

joelgeri1@gmail.com posted this 14 August 2019

I am new to code users and didn't know AMP was for Minecraft

openjdk version "1.8.0_222"
    OpenJDK Runtime Environment (build 1.8.0_222-8u222-b10-1ubuntu1~18.04.1-b10)
    OpenJDK 64-Bit Server VM (build 25.222-b10, mixed mode)

Mike posted this 14 August 2019

AMP supports lots of applications, including Minecraft. You should be fine, just ignore the message and hit start.

joelgeri1@gmail.com posted this 14 August 2019

ok, i just pulled the trigger and bought AMP

Close