wierd way of doing things + problem for creating instances

  • Last Post 11 August 2017
  • Topic Is Solved
vigilian posted this 11 August 2017

Is this a specific windows web app wrote in .net ? because seems to me that it has really big problems on linux to run no ?

First I would like to notice you that you have a problem with password with character like *&# ...

    Server Error in '/' Application.

A potentially dangerous Request.Form value was detected from the client (Password="...m&IAbOfgVC&#Y0tGC1NoOaCqn#Ewv2...").

Second, I've followed your quick tutorial on centos. So first unzip and create dir + create and launch ADS interface right?? Well first thing I would like to ask is: is it a process I will need to relaunch at each startup then? I've done this interface, and now I wanted to create a new instance of mcmyadmin but it doesn't work. The creation process executed itself but then impossible to start it from the AMP interface or with the command line and I do'nt have any error messages:

[Debug] Started process with ID 12720
[Debug] Starting process /bin/uname
[Debug] Working Directory: /home/AMP/AMP
[Debug] Arguments: -m
[Debug] Started process with ID 12721
[Debug] Running /bin/tmux -f /dev/null new-session -s "AMP_myadmin" -d "cd '/home/AMP/.ampdata/instances/myadmin' --; /home/AMP/.ampdata/instances/myadmin/AMP_Linux_x86_64 "
[Debug] Starting process /bin/tmux
[Debug] Working Directory: /home/AMP/.ampdata/instances/myadmin
[Debug] Arguments: -f /dev/null new-session -s "AMP_myadmin" -d "cd '/home/AMP/.ampdata/instances/myadmin' --; /home/AMP/.ampdata/instances/myadmin/AMP_Linux_x86_64 "
[Debug] Started process with ID 12723
[Info] You can now browse to this instances web interface at its IP address and port.
[Info] Instance started in new session. Run './ampinstmgr View myadmin' to view this instances console.
[AMP@mcmyadmin AMP]$ ./ampinstmgr view myadmin
[Info] AMP Instance Manager v1.4.8.0
[Debug] Loading instances from /home/AMP/.ampdata/instances.json...
[Debug] Loaded 2 instances.
[Debug] Starting process /bin/uname
[Debug] Working Directory: /home/AMP/AMP
[Debug] Arguments: -m
[Debug] Started process with ID 12741
[Notice] myadmin is not running.
[AMP@mcmyadmin AMP]$ 

I would like to notice too that if you create an isntance by only the commandline interface then it isn't write down on the ADS interface.... is it on purpose?

I've seen also that you use only windows file essentially.... Is it an emulation program that's running the web app? if you can't do a linux native web app then tell us to setup a windows nano server or something like that....

Order By: Standard | Newest | Votes
Mike posted this 11 August 2017

That error you see above isn't coming from AMP, AMP is API driven and doesn't use requests like that. It's also not an AMP style error message.

If an instance doesn't start you need to check it's log file. You can find this in ~/.ampdata/instances/INSTANCENAME/AMP_Logs

AMP is a full native Linux application, there's no emulation. The main AMP download includes both Linux and Windows versions just to keep things simple rather than two separate archives for the different platforms. It also means that instances can simply be copied from one platform to another and they'll still work.

To start your instances automatically on startup you'd need to add a line to your cron tab that runs the instance manager and tells it to start instances with the boot-time flag.

You shouldn't use the command line instance manager while ADS is running, use one or the other but not both. ADS doesn't re-read its instances list while it's running. Right now ADS isn't entirely working properly so it's recommended that you just use the command line tool to create/start/stop your instances.

vigilian posted this 11 August 2017

that error that I've put at the beginning from my post is the error from your forum not AMP. sorry for the misunderstanding

vigilian posted this 11 August 2017

sor for the error in the logs it tells me : 18:14:08] [Core:System Error]    : AMP may not run without a licence.

But I've completed the license key in the configuration manager ADS. + I've launched ADS with a license key so I would expect that ADS retain this information to use it later, since you want that to be the instance manager... Anyway it s the same error when I try to launch it by CLI with a license key....

So well understood for the non-relistening to the instance created.

another thing, each time I push refresh on the browser it goes to the login page .... very annoying. It shouldn't be doing that.

vigilian posted this 11 August 2017

  • there is no space on the form for instance creation on ADS to entry the key specified for this instance in particular by the way....

Mike posted this 11 August 2017

If you go Configuration -> Defaults there's a space to enter the licence key used for creating instances - check that it has a value. Also ADS can't create McMyAdmin instances as they use a different type of key, you must use the Minecraft option instead (They're the same thing except for the type of licence they take)

AMP is a single-page application, so it has to re-initialise everything when you refresh the page. If you pick the option to remember your login though it'll log you back in automatically when you refresh.

You can manually (re)activate an instance on the command line as follows:

./AMP_Linux_x86_64 +Core.AMP.LicenceKey YOURKEYHERE -configonly

Which is done in the datastore directory for the relevant instance.

vigilian posted this 11 August 2017

Ok now it has worked. May I suggest you that you add a small message in the former of Mcmyadmin and at least a place to enter the other key then?

And yes in defaults I ve put my key after the first failure.

Could you tell me if the ark instance use steamcmd? Because I have already steamcmd+ark+ark-server-tools installed. So if there are any incompatibilities it would be great to know. Maybe you could pin a thread with all the incompatibilities we know about? Like if there are some modded minecraft pack your system doesn t allow or ark management system and other things maybe? Thanks for your help Any way.

Mike posted this 11 August 2017

Yes, AMP uses steamcmd wherever possible to download and update apps. There aren't any major incompatibilities like that, the sole exception is that if some tool requires RCON to manage the server you can't use it right now as AMP takes control over RCON, and that AMP always launches the application directly so you can't use anything that's a wrapper. A quick glance suggests that you can't use ark-server-tools with AMP since AMP is meant to do most of the same things.