windows 2016 install issues

  • Last Post 13 April 2018
Smotel posted this 12 April 2018

hello there!

beeing a new user to AMP, i ran into a few problems with my installation and hope someone can point me into the right direction.

trying to install it on a clean win2016 server, i ran into what looks like permissions issues.

  1. after first installing an ads instance and then trying to deploy an minecraft instance, the ads fails to start / stop the minecraft instance from the webinterface. also on the webbased instance status page, the colors of the instances wont reflect if its runnning or not, even if its started / stopped thru the application itself.

  2. file permission issues. i did choose to put the instances payload folder onto a secondary drive, however it seems it will not change configuration files even tho the webinterface reflects those changes properly. ( i did grant NETWORK SERVICE full access to said folder )

  3. is there any documentation on how to install this from scratch on windows?

  4. should i try using the nightly builds?

sorry if i asked questions allready asked, i did spend quite a while going tho this support forums but couldnt find something that actualy fixes my issues.

thanks for any pointers in advance!

Order By: Standard | Newest | Votes
Mike posted this 12 April 2018

Did you make sure to create a new user as per the install guide? Using the Administrator user will break stuff.

Smotel posted this 12 April 2018

thanks for the quick reply!

I was indeed using a custom user with granted admin rights. The folders have full permissions for the user thats installs and for network service.

just did wipe it again( 4th time ) and started from scratch. it installs just fine, i can create the first ads instance just fine. however it starts to go wrong when launching this first instance. ( which i installed as a service aswell )

it will not even display the "running" checkbox filled when its been started thru the app. there is also no way to stop it cause the app doesnt recogonise it as "running" -.-

the webinterface looks fine after first login, ADS instance is displayed as green. however when i spawn a new minecraft instance for example from the app ( not thru the webinterface ) it will not even show up on the webinterface, not even after a relog.

do i have to fire those instances up thru services or will a right click+ start instance as the installing user do?

*edit after starting and stopping both instances from services, the minecraft one atleast shows up no under "local instances" but is red no matter if started or not. also trying to start it from the webinterface will do sweet fck all, not even getting an "starting instance" popup.

there is ZERO errors in the log files as far as i can see. there is a .net error in the event log however i think i caused that when i forcefully closed it last night on a previous attempt before rage quitting.

Application: AMPService.exe

Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.Net.Sockets.SocketException at System.Net.Sockets.Socket.DoBind(System.Net.EndPoint, System.Net.SocketAddress) at System.Net.Sockets.Socket.Bind(System.Net.EndPoint) at System.Net.Sockets.TcpListener.Start(Int32) at m.Http.HttpBackend.ConnectionLoop() at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object) at System.Threading.ThreadHelper.ThreadStart()

edit2* nvm found this in the log

You cannot start instances you do not own as a non-root user. You are *machinename*$ and this instance belongs to *username*.

( changed usrname and machinename )

any more good ideas for me before i trash this rig?

Mike posted this 12 April 2018

I'd suggest upgrading to the Nightly builds. It's hard to diagnose anything in 1.6 right now due to its age (1.7 is coming soon). I'd also recommend creating an ADS instance and using that to manage everything.

Smotel posted this 12 April 2018

yeah i wanted to try this now tho i can not asssign cpu affinity when creating instances thru the web ADS or?

Mike posted this 12 April 2018

No, but there's no point anyway. The OS will always do a better job. Only reason to use the affinity settings is when you're a host and want to lock customers to specific cores to prevent them overusing resources.

Smotel posted this 13 April 2018

i worry about affinity later and yes it would be quite usefull to exclude some cores as i am running other services on this machine aswell that i would likle to have dedicated to their taks.

tried to install the nightlys today, followed the howto, used 7zip, extracted the zip file over a fresh ADS instance, this is what i get trying to login.

Salt Parse
Invalid salt version

Thrown by the 'Core' plugin while performing the 'Login' method.

  • Liked by
  • GuyS
Mike posted this 13 April 2018

That's normal if you've never changed your password. If you run the following:

McMyAdmin.exe -setpass NEWPASSWORD

That'll reset your main admin password.

Smotel posted this 13 April 2018

This happens if i deploy a new instance from the webinterface putting in a custom username & password. This only happens tho if i toggle on the switch for using "nightly builds", with a deployed 1.6 instance it works without an error.

Is this an 1.7 feature that even tho i setup a username & password on the deploy page that i still need to manually change it?

I actualy thought that AMP is gonne save me some time and hassle, but atleast for a windows install this doesnt really seems to be the case at the moment :(

Sorry man to be a pain in the behind posting so much about my issues installing this, maybe i should just leave it be for now.

Mike posted this 13 April 2018

Is ADS itself nightly? The best way to have things working right now is to get ADS Working as nightly, then set that to itself create nightly instances.

From 1.6 -> 1.7 the method used to store login details was changed. There's no issue upgrading if you've changed your password at least once, but if the password was never changed after creating the instance then it needs resetting.

Having nightly ADS creating nightly instances centralises the logins which also avoids this issue.

The experience on Windows is a little messy right now because the GUI instance manager is in the process of being retired and a new setup process put in place that just creates an ADS instance instead.

Smotel posted this 13 April 2018

hehe thank you for not giving up on me =)

And yes Windows is super painfull and i would pretty much prefer a clean linux setup tho i do not have that option for this dl380.

I will give it another shot tomorrow, i think. And yes i think i joined this party abit in between "chairs". The gameserver instances itself work pretty flawlessless, i give you that =)

Mike posted this 13 April 2018

That's a pretty fair way to put it. 1.6 is getting a bit long in the tooth but 1.7 is missing some important features before it can be released as a 'proper' release, but also has fixes for issues in 1.6 so it's a little weird right now straddling between the two.